ports/math/libfixmath/files/patch-CMakeLists.txt
2025-01-26 11:59:42 -08:00

27 lines
968 B
Text

--- CMakeLists.txt.orig 2023-08-08 06:08:53 UTC
+++ CMakeLists.txt
@@ -14,16 +14,22 @@ if(CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR)
if(CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR)
# We're in the root, define additional targets for developers.
+ if (BUILD_TESTING)
include(tests/tests.cmake)
+ endif()
file(GLOB fixsingen-srcs fixsingen/*.c)
+ if (BUILD_TESTING)
file(GLOB fixtest-srcs fixtest/*.c fixtest/*.h)
+ endif()
+ if (BUILD_TESTING)
add_executable(fixtest ${fixtest-srcs})
- target_link_libraries(fixtest PRIVATE libfixmath m)
+ target_link_libraries(fixtest PRIVATE m)
target_include_directories(fixtest PRIVATE ${CMAKE_SOURCE_DIR})
+ endif()
add_executable(fixsingen ${fixsingen-srcs})
- target_link_libraries(fixsingen PRIVATE libfixmath m)
+ target_link_libraries(fixsingen PRIVATE m)
target_include_directories(fixsingen PRIVATE ${CMAKE_SOURCE_DIR})
endif()