mirror of
https://git.freebsd.org/ports.git
synced 2025-05-21 03:23:10 -04:00
* PyQt5: update to 5.15.3 This is a minor feature and bug-fix release. There are corresponding releases of the other PyQt5-related packages. - Added the missing QImage.setAlphaChannel(). - Support for the QtNetworkAuth library has been moved to a separate PyQtNetworkAuth package. - Wheels no longer bundle the corresponding Qt libraries and instead automatically install them from an external wheel. * QScintilla2: update to 2.12.0 This adds support for Qt6 and removes support for Qt4. - Change the new distname (again)i due to a conflict - Use the new sip-build system * devel/py-qtbuilder: update to 1.9.0 * devel/py-sip: fix flavor for sip-distinfo PR: 253865 Exp-run by: antoine
14 lines
501 B
Python
14 lines
501 B
Python
--- sipbuild/project.py.orig 2021-02-25 12:33:48 UTC
|
|
+++ sipbuild/project.py
|
|
@@ -335,9 +335,9 @@ class Project(AbstractProject, Configurable):
|
|
generator=None, wheel_tag=None):
|
|
""" Return a sequence of command line arguments to invoke sip-distinfo.
|
|
"""
|
|
-
|
|
+ flavor = '{}-{}.{}'.format(sip_distinfo, self.py_major_version, self.py_minor_version)
|
|
args = [
|
|
- sip_distinfo,
|
|
+ flavor,
|
|
|
|
'--inventory',
|
|
inventory,
|