mirror of
https://git.freebsd.org/ports.git
synced 2025-05-20 19:13:27 -04:00
arm_bf16.h is installed by the ARM backend as well as AArch64 so handle that. Patch out upstream 6d7e428df611 which traded a false negative for a false positive when compiling compiler-rt for i386. Fix default options for 32-bit powerpc arches. PR: 281179
17 lines
904 B
Text
17 lines
904 B
Text
--- compiler-rt/lib/builtins/CMakeLists.txt.orig
|
|
+++ compiler-rt/lib/builtins/CMakeLists.txt
|
|
@@ -867,12 +867,10 @@
|
|
endif()
|
|
endif()
|
|
endif()
|
|
- check_c_source_compiles("_Float16 foo(_Float16 x) { return x; }
|
|
- int main(void) { return 0; }"
|
|
+ check_c_source_compiles("_Float16 foo(_Float16 x) { return x; }"
|
|
COMPILER_RT_HAS_${arch}_FLOAT16)
|
|
append_list_if(COMPILER_RT_HAS_${arch}_FLOAT16 -DCOMPILER_RT_HAS_FLOAT16 BUILTIN_CFLAGS_${arch})
|
|
- check_c_source_compiles("__bf16 foo(__bf16 x) { return x; }
|
|
- int main(void) { return 0; }"
|
|
+ check_c_source_compiles("__bf16 foo(__bf16 x) { return x; }"
|
|
COMPILER_RT_HAS_${arch}_BFLOAT16)
|
|
# Build BF16 files only when "__bf16" is available.
|
|
if(COMPILER_RT_HAS_${arch}_BFLOAT16)
|