mirror of
https://git.freebsd.org/ports.git
synced 2025-05-20 19:13:27 -04:00
I'm creating an entirely new port for rancid 3.x as the syntax for the router.db file is different and a blind upgrade will cause deletion of backed up devices and their configs from the repository if the user doesn't stop the cron jobs before updating the syntax. PR: 193351
37 lines
1.5 KiB
Text
37 lines
1.5 KiB
Text
--- etc/Makefile.in.orig 2014-09-05 15:59:57 UTC
|
|
+++ etc/Makefile.in
|
|
@@ -520,30 +520,10 @@
|
|
|
|
|
|
install-data-local: all
|
|
- @if test "$(DO_CONF_INSTALL)" = "yes"; then \
|
|
- if test -f $(DESTDIR)$(sysconfdir)/rancid.conf ; then \
|
|
- echo ""; \
|
|
- echo "WARNING: *** $(DESTDIR)$(sysconfdir)/rancid.conf exists. See "; \
|
|
- echo " *** $(pkgdatadir)/rancid.conf.sample for new"; \
|
|
- echo " *** examples."; \
|
|
- echo ""; \
|
|
- else \
|
|
- $(INSTALL_DATA) rancid.conf.sample $(DESTDIR)$(sysconfdir)/rancid.conf; \
|
|
- fi; \
|
|
- if test ! -f $(DESTDIR)$(sysconfdir)/rancid.types.conf ; then \
|
|
- $(INSTALL_DATA) rancid.types.conf $(DESTDIR)$(sysconfdir)/rancid.types.conf; \
|
|
- fi; \
|
|
- if test -f $(DESTDIR)$(sysconfdir)/lg.conf ; then \
|
|
- echo ""; \
|
|
- echo "WARNING: *** $(DESTDIR)$(sysconfdir)/lg.conf exists. See "; \
|
|
- echo " *** $(pkgdatadir)/lg.conf.sample for new"; \
|
|
- echo " *** examples."; \
|
|
- echo ""; \
|
|
- else \
|
|
- $(INSTALL_DATA) lg.conf.sample $(DESTDIR)$(sysconfdir)/lg.conf; \
|
|
- fi; \
|
|
- fi; \
|
|
- $(INSTALL_DATA) rancid.types.base $(DESTDIR)$(sysconfdir)/rancid.types.base
|
|
+ $(INSTALL_DATA) rancid.conf.sample $(DESTDIR)$(sysconfdir)
|
|
+ #$(INSTALL_DATA) rancid.types.conf $(DESTDIR)$(sysconfdir)
|
|
+ $(INSTALL_DATA) lg.conf.sample $(DESTDIR)$(sysconfdir)
|
|
+ $(INSTALL_DATA) rancid.types.base $(DESTDIR)$(sysconfdir)
|
|
|
|
lg.conf.sample: Makefile $(srcdir)/lg.conf.sample.in
|
|
rm -f lg.conf.sample lg.conf.sample.tmp; \
|