ports/java/jdk16/files/patch-j2se::font::Makefile
Greg Lewis 1bb6af069e . Replace some hardwired /usr/X11R6 instances with X11BASE. [1]
. Replace some hardwired /usr/local instances with LOCALBASE.
. Small Makefile restructure to keep related variables in one place.
. Add ipv6 to CATEGORIES if its enabled. [2]

PR:             106130 [2]
Submitted by:   Janos Mohacsi <janos.mohacsi@bsd.hu> [2]
Pointed out by: pointyhat (via kris) [1]
2006-12-11 17:10:52 +00:00

13 lines
417 B
Text

$FreeBSD$
--- ../../j2se/make/sun/font/Makefile.orig Sun Dec 10 21:51:17 2006
+++ ../../j2se/make/sun/font/Makefile Sun Dec 10 21:51:50 2006
@@ -125,7 +125,7 @@
# setup the list of libraries to link in...
ifeq ($(PLATFORM), bsd)
# XXXBSD: why here?
-OTHER_INCLUDES += -I/usr/X11R6/include
+OTHER_INCLUDES += -I$(X11BASE)/include
OTHER_LDLIBS += -lawt$(SUFFIX) $(LIBM) $(LIBCXX)
else
ifeq ($(PLATFORM), linux)