mirror of
https://git.freebsd.org/ports.git
synced 2025-05-17 09:33:11 -04:00
- port is rewritten from scratch - Warning: UI widgets are oddly sized, currently under investigation PR: 236792 Submitted by: Jonathan Chen <jonc@chen.org.nz> Reviewed by: mizhka@gmail.com, Curtis Hamilton Approved by: ljboiler@gmail.com (maintainer timeout) Relnotes: https://www.eclipse.org/eclipseide/2019-03/noteworthy/
235 lines
12 KiB
Text
235 lines
12 KiB
Text
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem/natives/unix/freebsd/Makefile eclipse.platform.resources/bundles/org.eclipse.core.filesystem/natives/unix/freebsd/Makefile
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem/natives/unix/freebsd/Makefile 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem/natives/unix/freebsd/Makefile 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -20,7 +20,7 @@
|
|
LIB_NAME_FULL = libunixfile_1_0_0.so
|
|
|
|
#Set this to be your OS type
|
|
-OS_TYPE = linux
|
|
+OS_TYPE = freebsd
|
|
|
|
#Set this to be the location of your JRE
|
|
ifeq (${JAVA_HOME},)
|
|
@@ -28,15 +28,11 @@
|
|
endif
|
|
|
|
JDK_INCLUDE = -I ${JAVA_HOME}/include -I ${JAVA_HOME}/include/${OS_TYPE}
|
|
-OPT_FLAGS=-O2 -g -s -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
|
|
+OPT_FLAGS=-O2 -g -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
|
|
|
|
core:
|
|
- gcc $(OPT_FLAGS) -fPIC -c $(JDK_INCLUDE) -o $(CORE.O) $(CORE.C)
|
|
- gcc $(OPT_FLAGS) -shared -Wl,-soname,$(LIB_NAME) -o $(LIB_NAME_FULL) $(CORE.O) -lc
|
|
+ ${CC} $(OPT_FLAGS) -fPIC -c $(JDK_INCLUDE) -o $(CORE.O) $(CORE.C)
|
|
+ ${CC} $(OPT_FLAGS) -shared -Wl,-soname,$(LIB_NAME) -o $(LIB_NAME_FULL) $(CORE.O) -lc
|
|
|
|
clean:
|
|
rm -f $(CORE.O) $(LIB_NAME_FULL)
|
|
-
|
|
-install: core
|
|
- rm -f ../../../../org.eclipse.core.filesystem.linux.x86/os/linux/x86/libunixfile_1_0_0.so
|
|
- mv libunixfile_1_0_0.so ../../../../org.eclipse.core.filesystem.linux.x86/os/linux/x86/
|
|
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/.project eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/.project
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/.project 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/.project 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -1,6 +1,6 @@
|
|
<?xml version="1.0" encoding="UTF-8"?>
|
|
<projectDescription>
|
|
- <name>org.eclipse.core.filesystem.linux.x86_64</name>
|
|
+ <name>org.eclipse.core.filesystem.freebsd.amd64</name>
|
|
<comment></comment>
|
|
<projects>
|
|
</projects>
|
|
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/META-INF/MANIFEST.MF eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/META-INF/MANIFEST.MF
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/META-INF/MANIFEST.MF 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/META-INF/MANIFEST.MF 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -1,9 +1,9 @@
|
|
Manifest-Version: 1.0
|
|
Bundle-ManifestVersion: 2
|
|
Bundle-Name: %fragmentName
|
|
-Bundle-SymbolicName: org.eclipse.core.filesystem.linux.x86_64; singleton:=true
|
|
+Bundle-SymbolicName: org.eclipse.core.filesystem.freebsd.amd64; singleton:=true
|
|
Bundle-Version: 1.2.300.qualifier
|
|
Bundle-Vendor: %providerName
|
|
Fragment-Host: org.eclipse.core.filesystem;bundle-version="[1.7.200,2.0.0)"
|
|
Bundle-Localization: fragment
|
|
-Eclipse-PlatformFilter: (& (osgi.os=linux) (osgi.arch=x86_64))
|
|
+Eclipse-PlatformFilter: (& (osgi.os=freebsd) (osgi.arch=amd64))
|
|
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/pom.xml eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/pom.xml
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.amd64/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -18,7 +18,7 @@
|
|
<relativePath>../../</relativePath>
|
|
</parent>
|
|
<groupId>org.eclipse.core</groupId>
|
|
- <artifactId>org.eclipse.core.filesystem.linux.x86_64</artifactId>
|
|
+ <artifactId>org.eclipse.core.filesystem.freebsd.amd64</artifactId>
|
|
<version>1.2.300-SNAPSHOT</version>
|
|
<packaging>eclipse-plugin</packaging>
|
|
|
|
@@ -33,9 +33,9 @@
|
|
<resolver>p2</resolver>
|
|
<environments>
|
|
<environment>
|
|
- <os>linux</os>
|
|
+ <os>freebsd</os>
|
|
<ws>gtk</ws>
|
|
- <arch>x86_64</arch>
|
|
+ <arch>amd64</arch>
|
|
</environment>
|
|
</environments>
|
|
</configuration>
|
|
@@ -50,7 +50,7 @@
|
|
<property>
|
|
<!-- This has to be hardcoded. Profiles are not allowed to use pom defined properties :-( -->
|
|
<name>native</name>
|
|
- <value>gtk.linux.x86_64</value>
|
|
+ <value>gtk.freebsd.amd64</value>
|
|
</property>
|
|
</activation>
|
|
<build>
|
|
@@ -63,10 +63,10 @@
|
|
<phase>process-resources</phase>
|
|
<configuration>
|
|
<target>
|
|
- <exec executable="make" newenvironment="false" dir="../org.eclipse.core.filesystem/natives/unix/linux/"/>
|
|
- <mkdir dir="os/linux/x86_64/"/>
|
|
- <copy todir="os/linux/x86_64/">
|
|
- <fileset dir="../org.eclipse.core.filesystem/natives/unix/linux/">
|
|
+ <exec executable="gmake" newenvironment="false" dir="../org.eclipse.core.filesystem/natives/unix/freebsd/"/>
|
|
+ <mkdir dir="os/freebsd/amd64/"/>
|
|
+ <copy todir="os/freebsd/amd64/">
|
|
+ <fileset dir="../org.eclipse.core.filesystem/natives/unix/freebsd/">
|
|
<include name="libunixfile_*.so"/>
|
|
</fileset>
|
|
</copy>
|
|
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/META-INF/MANIFEST.MF eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/META-INF/MANIFEST.MF
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/META-INF/MANIFEST.MF 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/META-INF/MANIFEST.MF 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -1,9 +1,9 @@
|
|
Manifest-Version: 1.0
|
|
Bundle-ManifestVersion: 2
|
|
Bundle-Name: %fragmentName
|
|
-Bundle-SymbolicName: org.eclipse.core.filesystem.linux.x86; singleton:=true
|
|
+Bundle-SymbolicName: org.eclipse.core.filesystem.freebsd.i386; singleton:=true
|
|
Bundle-Version: 1.4.300.qualifier
|
|
Bundle-Vendor: %providerName
|
|
Fragment-Host: org.eclipse.core.filesystem;bundle-version="[1.7.200,2.0.0)"
|
|
Bundle-Localization: fragment
|
|
-Eclipse-PlatformFilter: (& (osgi.os=linux) (osgi.arch=x86))
|
|
+Eclipse-PlatformFilter: (& (osgi.os=freebsd) (osgi.arch=i386))
|
|
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/pom.xml eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/pom.xml
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.i386/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -18,7 +18,7 @@
|
|
<relativePath>../../</relativePath>
|
|
</parent>
|
|
<groupId>org.eclipse.core</groupId>
|
|
- <artifactId>org.eclipse.core.filesystem.linux.x86</artifactId>
|
|
+ <artifactId>org.eclipse.core.filesystem.freebsd.i386</artifactId>
|
|
<version>1.4.300-SNAPSHOT</version>
|
|
<packaging>eclipse-plugin</packaging>
|
|
|
|
@@ -33,9 +33,9 @@
|
|
<resolver>p2</resolver>
|
|
<environments>
|
|
<environment>
|
|
- <os>linux</os>
|
|
+ <os>freebsd</os>
|
|
<ws>gtk</ws>
|
|
- <arch>x86</arch>
|
|
+ <arch>i386</arch>
|
|
</environment>
|
|
</environments>
|
|
</configuration>
|
|
@@ -50,7 +50,7 @@
|
|
<property>
|
|
<!-- This has to be hardcoded. Profiles are not allowed to use pom defined properties :-( -->
|
|
<name>native</name>
|
|
- <value>gtk.linux.x86</value>
|
|
+ <value>gtk.freebsd.i386</value>
|
|
</property>
|
|
</activation>
|
|
<build>
|
|
@@ -63,9 +63,9 @@
|
|
<phase>process-resources</phase>
|
|
<configuration>
|
|
<target>
|
|
- <exec executable="make" newenvironment="false" dir="../org.eclipse.core.filesystem/natives/unix/linux/"/>
|
|
- <copy todir="os/linux/x86">
|
|
- <fileset dir="../org.eclipse.core.filesystem/natives/unix/linux/">
|
|
+ <exec executable="gmake" newenvironment="false" dir="../org.eclipse.core.filesystem/natives/unix/freebsd/"/>
|
|
+ <copy todir="os/freebsd/i386">
|
|
+ <fileset dir="../org.eclipse.core.filesystem/natives/unix/freebsd/">
|
|
<include name="libunixfile_*.so"/>
|
|
</fileset>
|
|
</copy>
|
|
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/META-INF/MANIFEST.MF eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/META-INF/MANIFEST.MF
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/META-INF/MANIFEST.MF 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/META-INF/MANIFEST.MF 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -1,9 +1,9 @@
|
|
Manifest-Version: 1.0
|
|
Bundle-ManifestVersion: 2
|
|
Bundle-Name: %fragmentName
|
|
-Bundle-SymbolicName: org.eclipse.core.filesystem.linux.ppc64le;singleton:=true
|
|
+Bundle-SymbolicName: org.eclipse.core.filesystem.freebsd.powerpc64;singleton:=true
|
|
Bundle-Version: 1.4.100.qualifier
|
|
Bundle-Vendor: %providerName
|
|
Fragment-Host: org.eclipse.core.filesystem;bundle-version="[1.1.0,2.0.0)"
|
|
Bundle-Localization: fragment
|
|
-Eclipse-PlatformFilter: (& (osgi.os=linux) (osgi.arch=ppc64le))
|
|
+Eclipse-PlatformFilter: (& (osgi.os=freebsd) (osgi.arch=powerpc64))
|
|
diff -ru eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/pom.xml eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/pom.xml
|
|
--- eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/bundles/org.eclipse.core.filesystem.freebsd.powerpc64/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -18,7 +18,7 @@
|
|
<relativePath>../../</relativePath>
|
|
</parent>
|
|
<groupId>org.eclipse.core</groupId>
|
|
- <artifactId>org.eclipse.core.filesystem.linux.ppc64le</artifactId>
|
|
+ <artifactId>org.eclipse.core.filesystem.freebsd.powerpc64</artifactId>
|
|
<version>1.4.100-SNAPSHOT</version>
|
|
<packaging>eclipse-plugin</packaging>
|
|
|
|
@@ -33,9 +33,9 @@
|
|
<resolver>p2</resolver>
|
|
<environments>
|
|
<environment>
|
|
- <os>linux</os>
|
|
+ <os>freebsd</os>
|
|
<ws>gtk</ws>
|
|
- <arch>ppc64le</arch>
|
|
+ <arch>powerpc64</arch>
|
|
</environment>
|
|
</environments>
|
|
</configuration>
|
|
diff -ru eclipse.platform.resources/pom.xml eclipse.platform.resources/pom.xml
|
|
--- eclipse.platform.resources/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/pom.xml 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -52,8 +52,8 @@
|
|
|
|
<modules>
|
|
<module>bundles/org.eclipse.core.filesystem</module>
|
|
- <module>bundles/org.eclipse.core.filesystem.linux.ppc64le</module>
|
|
- <module>bundles/org.eclipse.core.filesystem.linux.x86_64</module>
|
|
+ <module>bundles/org.eclipse.core.filesystem.freebsd.powerpc64</module>
|
|
+ <module>bundles/org.eclipse.core.filesystem.freebsd.amd64</module>
|
|
<module>bundles/org.eclipse.core.filesystem.macosx</module>
|
|
<module>bundles/org.eclipse.core.filesystem.win32.x86_64</module>
|
|
|
|
diff -ru eclipse.platform.resources/tests/org.eclipse.core.tests.filesystem.feature/feature.xml eclipse.platform.resources/tests/org.eclipse.core.tests.filesystem.feature/feature.xml
|
|
--- eclipse.platform.resources/tests/org.eclipse.core.tests.filesystem.feature/feature.xml 0000-00-00 00:00:00.000000000 +0000
|
|
+++ eclipse.platform.resources/tests/org.eclipse.core.tests.filesystem.feature/feature.xml 0000-00-00 00:00:00.000000000 +0000
|
|
@@ -28,9 +28,9 @@
|
|
unpack="false"/-->
|
|
|
|
<plugin
|
|
- id="org.eclipse.core.filesystem.linux.x86_64"
|
|
- os="linux"
|
|
- arch="x86_64"
|
|
+ id="org.eclipse.core.filesystem.freebsd.amd64"
|
|
+ os="freebsd"
|
|
+ arch="amd64"
|
|
download-size="0"
|
|
install-size="0"
|
|
version="0.0.0"
|