ports/graphics/appleseed/files/patch-CMakeLists.txt
Alexey Dokuchaev 9dbff489d9 graphics/appleseed: try to unbreak and slightly improve the port (+)
Pull the patch from the Arch/AUR package to unbreak the build against
OSL version 1.13.7 and later.  While here, cleanup Imath 3.x support:
drop actually useless patch and fix detection logic in the right file
instead of polluting global CFLAGS and using naive search heuristics.

Nagged by:	pkg-fallout (after commit cfcb40e240)
2024-07-28 05:29:50 +00:00

64 lines
1.6 KiB
Text

--- CMakeLists.txt.orig 2019-08-31 15:49:01 UTC
+++ CMakeLists.txt
@@ -356,9 +356,7 @@ endif ()
if (USE_FIND_PACKAGE_FOR_EXR)
include_directories (
${IMATH_INCLUDE_DIRS}
- ${IMATH_INCLUDE_DIRS}/OpenEXR/
${OPENEXR_INCLUDE_DIRS}
- ${OPENEXR_INCLUDE_DIRS}/OpenEXR/
)
else ()
include_directories (
@@ -681,8 +679,8 @@ if (WITH_PYTHON2_BINDINGS OR WITH_PYTHON3_BINDINGS)
endif ()
if (WITH_STUDIO)
- if (NOT WITH_PYTHON2_BINDINGS)
- message (FATAL_ERROR "Option WITH_PYTHON2_BINDINGS should be \"ON\" to build appleseed.studio.")
+ if (NOT WITH_PYTHON3_BINDINGS)
+ message (FATAL_ERROR "Option WITH_PYTHON3_BINDINGS should be \"ON\" to build appleseed.studio.")
endif ()
add_subdirectory (src/appleseed.studio)
endif ()
@@ -732,15 +730,27 @@ install (
sandbox/share
sandbox/stylesheets
DESTINATION .
+ PATTERN "cmake" EXCLUDE
)
install (
- FILES
+ DIRECTORY
+ sandbox/share/cmake
+ DESTINATION ../share
+)
+
+install (
+ PROGRAMS
scripts/cleanmany.py
scripts/convertmany.py
scripts/rendermanager.py
scripts/rendermany.py
scripts/rendernode.py
+ DESTINATION bin
+)
+
+install_relative_symlink (
+ ${CMAKE_INSTALL_PREFIX}
${OSL_COMPILER}
${OSL_QUERY_INFO}
${OSL_MAKETX}
@@ -754,11 +764,6 @@ install (
sandbox/schemas/settings.xsd
sandbox/schemas/project.xsd
DESTINATION schemas
-)
-
-install (
- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images)"
- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images/autosave)"
)
if (INSTALL_HEADERS)