mirror of
https://git.freebsd.org/ports.git
synced 2025-05-21 19:35:28 -04:00
Mk/Uses/qmake.mk: - Add support for out-of-source builds - Add support for Qt 5 ports - Respect WITH_DEBUG Mk/bsd.qt.mk: - Massive rework for Qt 5 ports - Remove '-phonon' from global configure args, thus allow qt4-designer and qt4-qtconfig to be built without Phonon support [1] devel/qmake4: - Improve mkspecs for gcc (mainly sync with linux version) and clang devel/qt4-corelib: - Convert to USES=iconv - Remove ancient patch devel/qt4-designer: - Remove reference to WRKSRC from installed pkgconfig files [2] - Don't build Qt Designer plugin for Phonon from outdated Qt sources. Separate port for plugin will be committed later devel/qt4-assistant-adp, devel/qt4-libqtassistantclient: - Convert to USES=qmake Clean up Qt4 ports: - Update comments - Update description; use common description - Consistently use QT_INCDIR, QT_LIBDIR, etc. - Use options helpers - Convert to new LIB_DEPENDS syntax - Update DESKTOP_ENTRIES to avoid conflicts with Qt 5 ports - Rename/move several ports for unification with Qt 5 ports PR: ports/184620 [1] Reported by: Kevin Zheng <kevinz5000@gmail.com> PR: ports/181141 [2] Reported by: thierry PR: ports/185101 Exp-run by: bdrewery This is mostly solely avilla's work in area51, kudos to him! And a couple commits from myself, so you know who's collecting pointyhats :)
51 lines
1.4 KiB
Text
51 lines
1.4 KiB
Text
--- ../mkspecs/freebsd-g++/qmake.conf.orig 2013-06-07 05:17:00.000000000 +0000
|
|
+++ ../mkspecs/freebsd-g++/qmake.conf 2013-12-05 23:07:25.210153920 +0000
|
|
@@ -8,47 +8,7 @@
|
|
CONFIG += qt warn_on release link_prl gdb_dwarf_index
|
|
QT += core gui
|
|
|
|
-QMAKE_CFLAGS_THREAD = -pthread -D_THREAD_SAFE
|
|
-
|
|
-QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD
|
|
-
|
|
-# Addon software goes into /usr/local on the BSDs, by default we will look there
|
|
-QMAKE_INCDIR = /usr/local/include
|
|
-QMAKE_LIBDIR = /usr/local/lib
|
|
-QMAKE_INCDIR_X11 = /usr/X11R6/include
|
|
-QMAKE_LIBDIR_X11 = /usr/X11R6/lib
|
|
-QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
|
|
-QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
|
|
-QMAKE_INCDIR_OPENGL = /usr/X11R6/include
|
|
-QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
|
|
-
|
|
-QMAKE_LFLAGS_THREAD = -pthread
|
|
-
|
|
-QMAKE_LIBS =
|
|
-QMAKE_LIBS_DYNLOAD =
|
|
-QMAKE_LIBS_X11 = -lXext -lX11 -lm
|
|
-QMAKE_LIBS_X11SM = -lSM -lICE
|
|
-QMAKE_LIBS_OPENGL = -lGL
|
|
-QMAKE_LIBS_OPENGL_QT = -lGL
|
|
-QMAKE_LIBS_THREAD =
|
|
-
|
|
-QMAKE_MOC = $$[QT_INSTALL_BINS]/moc
|
|
-QMAKE_UIC = $$[QT_INSTALL_BINS]/uic
|
|
-
|
|
-QMAKE_AR = ar cqs
|
|
-QMAKE_OBJCOPY = objcopy
|
|
-QMAKE_RANLIB =
|
|
-
|
|
-QMAKE_TAR = tar -cf
|
|
-QMAKE_GZIP = gzip -9f
|
|
-
|
|
-QMAKE_COPY = cp -f
|
|
-QMAKE_MOVE = mv -f
|
|
-QMAKE_DEL_FILE = rm -f
|
|
-QMAKE_DEL_DIR = rmdir
|
|
-QMAKE_CHK_DIR_EXISTS = test -d
|
|
-QMAKE_MKDIR = mkdir -p
|
|
-include(../common/unix.conf)
|
|
+include(../common/freebsd.conf)
|
|
include(../common/gcc-base-unix.conf)
|
|
include(../common/g++-unix.conf)
|
|
load(qt_config)
|