ports/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt
Tobias C. Berner 8bd38ffae8 New port: devel/grantlee5 and Uses/grantlee.mk
The upcoming KDE Frameworks ports need grantlee5

*  Add devel/grantlee5 and move installed headers into a subdirectory include/grantlee5
*  Move header files from devel/grantlee into a subdirectory
       include/grantlee4
   to make sure ports do not pick up the wrong headers
*  Add Uses/grantlee.mk to handle the PLIST_SUB and LIB_DEEPENDS needed
   by ports using grantlee (before we set the PLIST_SUB manual in very
   of the depending ports, which now should not be needed anymore).
*  The ports depending on devel/grantlee have been modified from
      LIB_DEPENDS=libgrantlee_gui.so:devel/grantlee
   to
      USES=grantlee:4
   as this does not affect the package no version bumped was made.

Reviewed by:    mat, rakuco
Approved by:    rakuco (mentor)
Differential Revision:  https://reviews.freebsd.org/D7434
2016-08-15 15:36:19 +00:00

14 lines
571 B
Text

Install headers prefixed, as to not cause a possible conflict with
different versions.
--- textdocument/lib/CMakeLists.txt.orig 2016-08-10 16:06:47 UTC
+++ textdocument/lib/CMakeLists.txt
@@ -44,7 +44,7 @@ install(TARGETS grantlee_gui EXPORT gran
RUNTIME DESTINATION ${BIN_INSTALL_DIR} COMPONENT TextDocument
LIBRARY DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
ARCHIVE DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
- INCLUDES DESTINATION include
+ INCLUDES DESTINATION include/grantlee4
)
install(FILES