mirror of
https://git.freebsd.org/ports.git
synced 2025-05-17 09:33:11 -04:00
34 lines
1.1 KiB
Text
34 lines
1.1 KiB
Text
--- scripts/CMakeLists.txt.orig 2015-10-19 06:15:50.000000000 +0300
|
|
+++ scripts/CMakeLists.txt 2016-06-20 22:08:33.133152000 +0300
|
|
@@ -19,27 +19,19 @@
|
|
endforeach()
|
|
endif()
|
|
|
|
-if(BUILD_SHARED_LIBS)
|
|
- add_library(pugixml SHARED ${SOURCES})
|
|
-else()
|
|
- add_library(pugixml STATIC ${SOURCES})
|
|
-endif()
|
|
-
|
|
-# Enable C++11 long long for compilers that are capable of it
|
|
-if(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} STRLESS 3.1)
|
|
- target_compile_features(pugixml PUBLIC cxx_long_long_type)
|
|
-endif()
|
|
+add_library(pugixml SHARED ${SOURCES})
|
|
+add_library(pugixml_static STATIC ${SOURCES})
|
|
|
|
set_target_properties(pugixml PROPERTIES VERSION 1.7 SOVERSION 1)
|
|
+set_target_properties(pugixml_static PROPERTIES OUTPUT_NAME pugixml)
|
|
|
|
-install(TARGETS pugixml EXPORT pugixml-config
|
|
+install(TARGETS pugixml pugixml_static
|
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
|
)
|
|
|
|
install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
|
|
-install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
|
|
|
|
if(BUILD_TESTS)
|
|
file(GLOB TEST_SOURCES ../tests/*.cpp)
|