mirror of
https://git.freebsd.org/ports.git
synced 2025-05-28 17:06:32 -04:00
* Define LICENSE * Clean up Makefile * Import patches from Debian and Gentoo for various bug fixes References: https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0001-configure.in-adjust-variable-formatting.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0002-ogmsplit.1-spell-correct.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0003-ogmmerge-spell-correct.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0004-ogminfo-timestamp-correction.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0006-pass-CFLAGS.patch/ https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/ogmtools/files/ogmtools-1.5-comments.patch https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/ogmtools/files/ogmtools-1.5-endian-fix.patch https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/ogmtools/files/ogmtools-1.5-gcc11.patch
21 lines
1 KiB
C
21 lines
1 KiB
C
--- vorbis_header_utils.c.orig 2003-10-23 19:46:32 UTC
|
|
+++ vorbis_header_utils.c
|
|
@@ -153,15 +153,15 @@ vorbis_comment *vorbis_comment_dup(vorbis_comment *vc)
|
|
die("malloc");
|
|
|
|
memcpy(new_vc, vc, sizeof(vorbis_comment));
|
|
- new_vc->user_comments = (char **)malloc((vc->comments + 1) * sizeof(char *));
|
|
- new_vc->comment_lengths = (int *)malloc((vc->comments + 1) * sizeof(int));
|
|
+ new_vc->user_comments = (char **)malloc((vc->comments + 1) * sizeof(*new_vc->user_comments));
|
|
+ new_vc->comment_lengths = (int *)malloc((vc->comments + 1) * sizeof(*new_vc->comment_lengths));
|
|
if ((new_vc->user_comments == NULL) || (new_vc->comment_lengths == NULL))
|
|
die("malloc");
|
|
for (i = 0; i < vc->comments; i++)
|
|
new_vc->user_comments[i] = strdup(vc->user_comments[i]);
|
|
new_vc->user_comments[vc->comments] = 0;
|
|
memcpy(new_vc->comment_lengths, vc->comment_lengths,
|
|
- (vc->comments + 1) * sizeof(char *));
|
|
+ (vc->comments + 1) * sizeof(*new_vc->comment_lengths));
|
|
new_vc->vendor = strdup(vc->vendor);
|
|
|
|
return new_vc;
|