mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
* Define LICENSE * Clean up Makefile * Import patches from Debian and Gentoo for various bug fixes References: https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0001-configure.in-adjust-variable-formatting.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0002-ogmsplit.1-spell-correct.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0003-ogmmerge-spell-correct.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0004-ogminfo-timestamp-correction.patch/ https://sources.debian.org/src/ogmtools/1%3A1.5-4.1/debian/patches/0006-pass-CFLAGS.patch/ https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/ogmtools/files/ogmtools-1.5-comments.patch https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/ogmtools/files/ogmtools-1.5-endian-fix.patch https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/ogmtools/files/ogmtools-1.5-gcc11.patch
11 lines
358 B
C
11 lines
358 B
C
--- avilib/avidump.c.orig 2004-11-02 15:30:16 UTC
|
|
+++ avilib/avidump.c
|
|
@@ -54,7 +54,7 @@
|
|
((x<<8) & 0x00ff0000) |\
|
|
((x<<24) & 0xff000000))
|
|
# define SWAP8(x) (((SWAP4(x)<<32) & 0xffffffff00000000ULL) |\
|
|
- (SWAP4(x)))
|
|
+ SWAP4(x))
|
|
#else
|
|
# define SWAP2(a) (a)
|
|
# define SWAP4(a) (a)
|