ports/net-im/py-matrix-synapse/files/patch-pyproject.toml
Sascha Biberhofer ed0cc647e1
net-im/py-matrix-synapse: Update to 1.120.2
Signed-off-by: Sascha Biberhofer <sascha.biberhofer@skyforge.at>

PR:		283350
Security:	71f3e9f0-bafc-11ef-885d-901b0e934d69
Security:	CVE-2024-52805
Security:	CVE-2024-52815
Security:	CVE-2024-53863
Security:	CVE-2024-53867
Security:	CVE-2024-37302
Security:	CVE-2024-37303
MFH:		2024Q4
2024-12-16 22:13:54 +00:00

28 lines
1.2 KiB
TOML

--- pyproject.toml.orig 2024-07-16 11:51:30 UTC
+++ pyproject.toml
@@ -215,16 +215,6 @@ pydantic = ">=1.7.4, <3"
# See https://github.com/matrix-org/synapse/issues/15858
pydantic = ">=1.7.4, <3"
-# This is for building the rust components during "poetry install", which
-# currently ignores the `build-system.requires` directive (c.f.
-# https://github.com/python-poetry/poetry/issues/6154). Both `pip install` and
-# `poetry build` do the right thing without this explicit dependency.
-#
-# This isn't really a dev-dependency, as `poetry install --no-dev` will fail,
-# but the alternative is to add it to the main list of deps where it isn't
-# needed.
-setuptools_rust = ">=1.3"
-
# This is used for parsing multipart responses
python-multipart = ">=0.0.9"
@@ -372,7 +362,7 @@ tomli = ">=1.2.3"
# runtime errors caused by build system changes.
# We are happy to raise these upper bounds upon request,
# provided we check that it's safe to do so (i.e. that CI passes).
-requires = ["poetry-core>=1.1.0,<=1.9.1", "setuptools_rust>=1.3,<=1.8.1"]
+requires = ["poetry-core>=1.1.0,<=1.9.1", "setuptools_rust>=1.3,<=1.10.2"]
build-backend = "poetry.core.masonry.api"