ports/devel/py-optree/files/patch-setup.py
Po-Chuan Hsieh 2852bacb2e
devel/py-optree: Add py-optree 0.10.0
OpTree provides optimized PyTree utilities.

A PyTree is a recursive structure that can be an arbitrarily nested Python
container (e.g., tuple, list, dict, OrderedDict, NamedTuple, etc.) or an opaque
Python object. The key concepts of tree operations are tree flattening and its
inverse (tree unflattening). Additional tree operations can be performed based
on these two basic functions.
2023-12-25 16:56:51 +08:00

18 lines
549 B
Python

--- setup.py.orig 2023-11-07 06:45:50 UTC
+++ setup.py
@@ -67,15 +67,6 @@ class cmake_build_ext(build_ext): # noqa: N801
pass
build_args = ['--config', config]
- if (
- 'CMAKE_BUILD_PARALLEL_LEVEL' not in os.environ
- and hasattr(self, 'parallel')
- and self.parallel
- ):
- build_args.extend(['--parallel', str(self.parallel)])
- else:
- build_args.append('--parallel')
-
build_args.extend(['--target', ext.target, '--'])
try: