mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
OpTree provides optimized PyTree utilities. A PyTree is a recursive structure that can be an arbitrarily nested Python container (e.g., tuple, list, dict, OrderedDict, NamedTuple, etc.) or an opaque Python object. The key concepts of tree operations are tree flattening and its inverse (tree unflattening). Additional tree operations can be performed based on these two basic functions.
18 lines
549 B
Python
18 lines
549 B
Python
--- setup.py.orig 2023-11-07 06:45:50 UTC
|
|
+++ setup.py
|
|
@@ -67,15 +67,6 @@ class cmake_build_ext(build_ext): # noqa: N801
|
|
pass
|
|
|
|
build_args = ['--config', config]
|
|
- if (
|
|
- 'CMAKE_BUILD_PARALLEL_LEVEL' not in os.environ
|
|
- and hasattr(self, 'parallel')
|
|
- and self.parallel
|
|
- ):
|
|
- build_args.extend(['--parallel', str(self.parallel)])
|
|
- else:
|
|
- build_args.append('--parallel')
|
|
-
|
|
build_args.extend(['--target', ext.target, '--'])
|
|
|
|
try:
|