mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 02:26:38 -04:00
- Convert to USES=waf (respects MAKE_JOBS_NUMBER) - Convert to option helpers - Define WRKSRC_SUBDIR after adjusting patches - Drop/rename common option and their descriptions - pkg-plist: rename WITH_DEBUG to DEBUG_SUFX to avoid confusion - pkg-plist: define VERSION to avoid churn on updates - post-install: compress multiple sh(1) loops via find(1) expressions PR: 208146 Approved by: Nikola Kolev (maintainer)
11 lines
401 B
Python
11 lines
401 B
Python
--- waf-tools/cflags.py.orig 2015-09-23 19:28:42 UTC
|
|
+++ waf-tools/cflags.py
|
|
@@ -19,7 +19,7 @@ class GccTraits(CompilerTraits):
|
|
def __init__(self):
|
|
super(GccTraits, self).__init__()
|
|
# cumulative list of warnings per level
|
|
- self.warnings_flags = [['-Wall'], ['-Werror'], ['-Wextra']]
|
|
+ self.warnings_flags = [['-Wall'], ['-Wextra']]
|
|
|
|
def get_warnings_flags(self, level):
|
|
warnings = []
|