ports/net/mosquitto/files/patch-src_CMakeLists.txt
Daniel Engberg 97400f86dc net/mosquitto: Link with correct library type when using websockets option
Libwebsockets refers to static library as websockets and shared as
websockets_shared. Currently it causes shared option in mosuitto to link
with static library and static option doesn't work at all.

PR:		269536
Reviewed by:	Joseph Benden <joe@thrallingpenguin.com> (maintainer)
2023-02-13 23:47:19 +01:00

18 lines
547 B
Text

--- src/CMakeLists.txt.orig 2023-02-13 19:40:35 UTC
+++ src/CMakeLists.txt
@@ -194,13 +194,13 @@ endif (WIN32)
if (WITH_WEBSOCKETS)
if (STATIC_WEBSOCKETS)
- set (MOSQ_LIBS ${MOSQ_LIBS} websockets_static)
+ set (MOSQ_LIBS ${MOSQ_LIBS} websockets)
if (WIN32)
set (MOSQ_LIBS ${MOSQ_LIBS} iphlpapi)
link_directories(${mosquitto_SOURCE_DIR})
endif (WIN32)
else (STATIC_WEBSOCKETS)
- set (MOSQ_LIBS ${MOSQ_LIBS} websockets)
+ set (MOSQ_LIBS ${MOSQ_LIBS} websockets_shared)
endif (STATIC_WEBSOCKETS)
endif (WITH_WEBSOCKETS)