mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 12:06:39 -04:00
Adjust configuration options to closer match other distributions and also upstream's recommendations. Mosquitto also requires LWS_WITH_EXTERNAL_POLL to be enabled when linked with this library. Enable following options: LWS_WITH_DISKCACHE, LWS_WITH_FTS, LWS_WITH_RANGES, LWS_WITH_THREADPOOL and (LWS_WITH_EXTERNAL_POLL via MQTT option). Use SHA1 via OpenSSL (LWS_WITHOUT_BUILTIN_SHA1) While at also adjust .cmake and .pc files to properly report version Changelog: https://github.com/warmcat/libwebsockets/blob/v4.3.0/changelog https://github.com/warmcat/libwebsockets/compare/v4.3.0...v4.3.2 PR: 262552 Reported by: Leo Schneider <ttkdroid@gmail.com> Tested by: Rod Morgan <rmorgan@portmorgan.com>
38 lines
1.3 KiB
Text
38 lines
1.3 KiB
Text
--- lib/CMakeLists.txt.orig 2023-02-14 23:28:15 UTC
|
|
+++ lib/CMakeLists.txt
|
|
@@ -316,7 +316,7 @@ includedir=\${prefix}/include
|
|
|
|
Name: libwebsockets
|
|
Description: Websockets server and client library
|
|
-Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}
|
|
+Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH_NUMBER}
|
|
|
|
Libs: -L\${libdir} -lwebsockets
|
|
Cflags: -I\${includedir}
|
|
@@ -328,7 +328,7 @@ endif()
|
|
|
|
|
|
install(FILES "${PROJECT_BINARY_DIR}/libwebsockets.pc"
|
|
- DESTINATION lib${LIB_SUFFIX}/pkgconfig)
|
|
+ DESTINATION libdata/pkgconfig)
|
|
|
|
file(WRITE "${PROJECT_BINARY_DIR}/libwebsockets_static.pc"
|
|
"prefix=\"${CMAKE_INSTALL_PREFIX}\"
|
|
@@ -338,7 +338,7 @@ includedir=\${prefix}/include
|
|
|
|
Name: libwebsockets_static
|
|
Description: Websockets server and client static library
|
|
-Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}
|
|
+Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH_NUMBER}
|
|
|
|
Libs: -L\${libdir} -l:libwebsockets${CMAKE_STATIC_LIBRARY_SUFFIX}
|
|
Libs.private:
|
|
@@ -352,7 +352,7 @@ endif()
|
|
|
|
|
|
install(FILES "${PROJECT_BINARY_DIR}/libwebsockets_static.pc"
|
|
- DESTINATION lib${LIB_SUFFIX}/pkgconfig)
|
|
+ DESTINATION libdata/pkgconfig)
|
|
|
|
endif(UNIX OR MINGW)
|
|
|