ports/ftp/wzdftpd/files/patch-ac-helpers__tls.m4
Robert Clausecker 2f04ed793d ftp/wzdftpd: fix build with LLVM 15
Seems like the compiler got a whole lot stricter with this release.
The biggest fix was changing the thread ID from unsigned long to
pthread_t, which will probably break compilation on Win32.

While we are at it, replace static uses of REINPLACE_CMD with patch
files as per policy.  This change is responsible for most of the
newly added patches.

The wzdftpd build scripts want to install plugins into ${PREFIX}/share
when they belong into ${PREFIX}/lib.  Instead of patching this in each
Makefile.am, set --datadir=${PREFIX}/lib and work around the one file
for which this is wrong.

Approved by:	eduardo (mentor)
Differential Revision: https://reviews.freebsd.org/D38523
2023-02-14 21:23:41 +01:00

11 lines
351 B
Text

--- ac-helpers/tls.m4.orig 2004-10-26 11:14:48 UTC
+++ ac-helpers/tls.m4
@@ -22,7 +22,7 @@ AC_DEFUN([WZD_TLS],
)
if test "$gnutls" = "yes"; then
-AM_PATH_LIBGNUTLS(0.9.8,wzd_have_gnutls=yes)
+PKG_CHECK_MODULES(LIBGNUTLS, [gnutls], [wzd_have_gnutls=yes], [wzd_have_gnutls=no])
fi
# openssl is checked only if gnutls was not found or disabled