mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 12:06:39 -04:00
- While I'm here, fix WWW Poetry is packing and dependency management utility for Python. It should not be used as BUILD_DEPENDS. Its PEP517 build backend is devel/py-poetry-core. Therefore, I fixed pyproject.toml and sent the pull request as well. Approved by: portmgr (blanket) With hat: python Reference: https://github.com/rigetti/qcs-api-client-python/blob/v0.21.5/pyproject.toml#L55-L57
10 lines
300 B
TOML
10 lines
300 B
TOML
--- pyproject.toml.orig 2023-05-03 18:28:26 UTC
|
|
+++ pyproject.toml
|
|
@@ -53,5 +53,5 @@ multi_line_output = 3
|
|
include_trailing_comma = true
|
|
|
|
[build-system]
|
|
-requires = ["poetry>=1.0"]
|
|
-build-backend = "poetry.masonry.api"
|
|
+requires = ["poetry-core>=1.0.0"]
|
|
+build-backend = "poetry.core.masonry.api"
|