mirror of
https://git.freebsd.org/ports.git
synced 2025-05-07 19:30:46 -04:00
- submiter becomes maintainer genht is a simple generic hash table implementation in C. Uses open addressing scheme with space doubling. Type generics is achieved by ugly name prefixing macros. WWW: http://www.repo.hu/projects/genht/ PR: 265261
11 lines
349 B
Text
11 lines
349 B
Text
--- src/Makefile.orig 2022-07-17 07:03:04 UTC
|
|
+++ src/Makefile
|
|
@@ -35,7 +35,7 @@ mainsi: mainsi.o htsi.o
|
|
$(CC) -o $@ mainsi.o htsi.o $(LDFLAGS)
|
|
|
|
$(LIBSO): $(OBJS)
|
|
- $(CC) $(LDFLAGS) -shared -dynamic -rdynamic -o $@ $(OBJS)
|
|
+ $(CC) $(LDFLAGS) -shared -dynamic -rdynamic -Wl,-soname,$(LIBSO1) -o $@ $(OBJS)
|
|
|
|
$(LIBA): $(OBJS)
|
|
ar rvu $@ $(OBJS)
|