ports/devel/genht/files/patch-src_Makefile
Robert Clausecker 5cb56fb0db devel/genht: New port: Simple generic hash table implementation in C
- submiter becomes maintainer

genht is a simple generic hash table implementation in C.
Uses open addressing scheme with space doubling.
Type generics is achieved by ugly name prefixing macros.

WWW: http://www.repo.hu/projects/genht/

PR:		265261
2022-07-18 08:00:24 +01:00

11 lines
349 B
Text

--- src/Makefile.orig 2022-07-17 07:03:04 UTC
+++ src/Makefile
@@ -35,7 +35,7 @@ mainsi: mainsi.o htsi.o
$(CC) -o $@ mainsi.o htsi.o $(LDFLAGS)
$(LIBSO): $(OBJS)
- $(CC) $(LDFLAGS) -shared -dynamic -rdynamic -o $@ $(OBJS)
+ $(CC) $(LDFLAGS) -shared -dynamic -rdynamic -Wl,-soname,$(LIBSO1) -o $@ $(OBJS)
$(LIBA): $(OBJS)
ar rvu $@ $(OBJS)