ports/security/nss/files/patch-..::coreconf::FreeBSD.mk
Florian Smeets d39d92427c - update firefox to 19.0
- update firefox-esr, thunderbird, linux-firefox, linux-thunderbird to 17.0.3
- update linux-seamonkey to 2.16
- update nspr to 4.9.5
- update nss to 3.14.3
- add DuckDuckGo search plugin to firefox [1]
- mark kompozer deprecated
- clang fixes for www/libxul19 [2]

Security:	http://www.vuxml.org/freebsd/e3f0374a-7ad6-11e2-84cd-d43d7e0c7c02.html
Submitted by:	DuckDuckGo [1], dim [2]
In collaboration with:	Jan Beich <jbeich@tormail.org>
2013-02-19 23:53:07 +00:00

64 lines
1.4 KiB
Makefile

--- ../../security/coreconf/FreeBSD.mk.orig 2009-08-22 07:33:09.000000000 +0200
+++ ../../security/coreconf/FreeBSD.mk 2010-03-28 23:01:33.000000000 +0200
@@ -37,9 +37,9 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
-DEFAULT_COMPILER = gcc
-CC = gcc
-CCC = g++
+DEFAULT_COMPILER = $(CC)
+CC ?= gcc
+CCC = $(CXX)
RANLIB = ranlib
CPU_ARCH = $(OS_TEST)
@@ -52,6 +52,13 @@ endif
ifeq ($(CPU_ARCH),amd64)
CPU_ARCH = x86_64
endif
+ifneq (,$(filter powerpc%, $(CPU_ARCH)))
+CPU_ARCH = ppc
+endif
+
+ifneq (,$(filter %64, $(OS_TEST)))
+USE_64 = 1
+endif
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -Wno-switch -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
@@ -65,20 +80,20 @@
USE_PTHREADS = 1
DEFINES += -D_THREAD_SAFE -D_REENTRANT
OS_LIBS += -pthread
-DSO_LDOPTS += -pthread
+DSO_LDOPTS += $(BSD_LDOPTS)
endif
ARCH = freebsd
-MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
+ifndef MOZILLA_CLIENT
+DLL_SUFFIX = so.1
+endif
-ifeq ($(MOZ_OBJFORMAT),elf)
-DLL_SUFFIX = so
+ifneq (,$(filter alpha ia64,$(OS_TEST)))
+MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS)
else
-DLL_SUFFIX = so.1.0
+MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS)
endif
-
-MKSHLIB = $(CC) $(DSO_LDOPTS)
ifdef MAPFILE
MKSHLIB += -Wl,--version-script,$(MAPFILE)
endif
@@ -87,4 +100,5 @@
G++INCLUDES = -I/usr/include/g++
-INCLUDES += -I/usr/X11R6/include
+USE_SYSTEM_ZLIB = 1
+ZLIB_LIBS = -lz