mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
PyQt5: - devel/py-qt5-pyqt: Update to 5.15.11 - graphics/py-qt5-3d: Add port - net/py-qt5-networkauth: Update to 5.15.6 - www/py-qt5-webengine: Update to 5.15.7 - x11-toolkits/py-qt5-chart: Update to 5.15.7 - x11-toolkits/py-qt5-datavis3d: Add port PyQt6: - devel/py-qt6-pyqt: Update to 6.7.1 Build tools: - devel/sip: Update to 6.8.6 - devel/py-qt5-sip: Update to 12.15.0 - devel/py-qt6-sip: Update to 13.8.0 - devel/py-qtbuilder: Update to 1.16.4 The build tools are now all licensed BSD2CLAUSE and have been converted to PEP517.
14 lines
525 B
Python
14 lines
525 B
Python
--- sipbuild/project.py.orig 2024-07-12 11:20:17 UTC
|
|
+++ sipbuild/project.py
|
|
@@ -408,9 +408,9 @@ class Project(AbstractProject, Configurable):
|
|
generator=None, wheel_tag=None, generator_version=None):
|
|
""" Return a sequence of command line arguments to invoke sip-distinfo.
|
|
"""
|
|
-
|
|
+ flavor = '{}-{}.{}'.format(sip_distinfo, self.py_major_version, self.py_minor_version)
|
|
args = [
|
|
- sip_distinfo,
|
|
+ flavor,
|
|
|
|
'--inventory',
|
|
inventory,
|