mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Screen 5.0.0 is the next major release of GNU Screen. Unfortunatly while testing sysutils/screen-devel I discovered bugs with its hardstatus implementation. Existing hardstatus failed to work correctly. I had opened a bug with the GNU Screen upstream. They had fixed one of the bugs however the last time I tested screen-devel, some status strings were still unavailable, not to mention that the hardstatus string syntax has changed. Therefore I don't believe screen50 should replace screen49 as our default GNU screen until a) some of the issues are resolved and b) we the FreeBSD community have had a little more experience with it. People who wish to use screen50 will need to uninstall screen (currently a meta port pointing to screen49) and install screen50. Any bugzilla bugs will likely spawn an upstream bug report by myself.
34 lines
1 KiB
Text
34 lines
1 KiB
Text
--- doc/Makefile.in.orig 2014-04-29 20:26:42.618832001 -0700
|
|
+++ doc/Makefile.in 2014-04-29 20:29:26.379384101 -0700
|
|
@@ -31,7 +31,10 @@
|
|
$(MAKEINFO) --no-split $(srcdir)/screen.texinfo -o screen.info
|
|
|
|
install: installdirs
|
|
+ifeq (${WITH_MAN},1)
|
|
$(INSTALL_DATA) $(srcdir)/screen.1 $(DESTDIR)$(mandir)/man1/screen.1
|
|
+endif
|
|
+ifeq (${WITH_INFO},1)
|
|
-$(MAKE) screen.info
|
|
-if test -f screen.info; then d=.; else d=$(srcdir); fi; \
|
|
if test -f $$d/screen.info; then \
|
|
@@ -40,13 +43,19 @@
|
|
install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/screen.info; \
|
|
else true; fi; \
|
|
fi
|
|
+endif
|
|
|
|
uninstall:
|
|
rm -f $(DESTDIR)$(mandir)/man1/screen.1
|
|
rm -f $(DESTDIR)$(infodir)/screen.info*
|
|
|
|
installdirs:
|
|
- $(srcdir)/../etc/mkinstalldirs $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(infodir)
|
|
+ifeq (${WITH_MAN},1)
|
|
+ $(srcdir)/../etc/mkinstalldirs $(DESTDIR)$(mandir)/man1
|
|
+endif
|
|
+ifeq (${WITH_INFO},1)
|
|
+ $(srcdir)/../etc/mkinstalldirs $(DESTDIR)$(infodir)
|
|
+endif
|
|
|
|
mostlyclean:
|
|
-rm -f *.cp *.cps *.fn *.fns *.ky *.kys *.pg *.tp *.vr
|