ports/emulators/virtualbox-ose-legacy/files/patch-src-VBox-HostDrivers-Makefile.kmk
Beat Gaetzi 804cd7e393 - Update to 3.2.2
- Update guest additions to 3.2.2.
- Add option to build with VNC support (Disabled by default)
- Add option to build with VDE support (Disabled by default) [1]
- Add option to build webservice (Disabled by default) [2]
- Fix build with QT4 support disabled and X11 support enabled. [3]
- Fix build with X11 support disabled. [4]
- Replace custom pkg-install.in script with GROUPS framework.
- Do not build Guest Additions in virtualbox-ose port.
- Implement locking/unlocking of host DVD drive. [5]
- Add LICENSE and LICENSE_FILE.

PR:		ports/146752 [5]
Submitted by:	mtm@ [5]
Requested by:	Mario Lobo <lobo AT bsd.com.br> [1],
		Hubert Tournier <hubert AT frbsd.org> [2]
Reported by:	Emil Mikulic <emil AT dmr.ath.cx> [3], mm@ [4]

Many thanks to the VirtualBox developers (especially Alexander Eichner
for all his work and help), all tester and patch submitter and the whole
vbox@ team especially decke@.
2010-06-07 16:31:58 +00:00

27 lines
797 B
Text

--- src/VBox/HostDrivers/Makefile.kmk.orig 2010-03-04 12:59:54.000000000 +0100
+++ src/VBox/HostDrivers/Makefile.kmk 2010-03-09 12:54:09.000000000 +0100
@@ -40,7 +40,7 @@
endif
endif
- if1of ($(KBUILD_TARGET),linux freebsd)
+ if1of ($(KBUILD_TARGET),linux)
#
# Install the Makefile for module compliation on Linux and FreeBSD hosts
#
@@ -51,6 +51,7 @@
HostDrivers-src_SOURCES.freebsd = freebsd/Makefile
endif
+if 0
if1of ($(KBUILD_TARGET),freebsd)
#
# Install the export_modules script for tar'ing the module sources on FreeBSD hosts
@@ -60,6 +61,7 @@
HostDrivers-sh_MODE = a+rx,u+w
HostDrivers-sh_SOURCES.freebsd = freebsd/export_modules
endif
+endif
endif # !defined(VBOX_ONLY_DOCS) && !defined(VBOX_ONLY_TESTSUITE)
# Let kBuild generate the rules.