ports/misc/libemos/files/patch-libemos-dp_CMakeLists.txt
Adriaan de Groot 9c45f5c8a9 Update devel/cmake to 3.15.2 (latest upstream release)
Release notes for the version updates are at:
	https://blog.kitware.com/cmake-3-15-0-available-for-download/
	https://blog.kitware.com/cmake-3-15-1-available-for-download/
	https://blog.kitware.com/cmake-3-15-2-available-for-download/

For FreeBSD, not much interesting has changed. Swift language support
might be useful.

A few ports were fixed as part of this exp-run (libemos not really
related to the CMake update, but in general). Thanks to antoine
for the exp-runs, tcberner for doing most of the prep-work.

PR:		239273
Submitted by:	tcberner
2019-08-14 14:18:36 +00:00

13 lines
668 B
Text

Fix build: the symlink to libemosR64.a was not created
in ${STAGEDIR}, leading to fs_violations during poudriere test-builds.
--- libemos-dp/CMakeLists.txt.orig 2019-08-10 23:48:55 UTC
+++ libemos-dp/CMakeLists.txt
@@ -42,6 +42,6 @@ ecbuild_add_library(
# libemosR64.so ${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R64.D64.I32.so)" )
#else()
install(CODE "execute_process(COMMAND \"${CMAKE_COMMAND}\" -E create_symlink
- libemosR64.a ${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R64.D64.I32.a)" )
+ libemosR64.a \$ENV{DESTDIR}/${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R64.D64.I32.a)" )
#endif()