ports/math/py-ambit/files/patch-CMakeLists.txt

11 lines
616 B
Text

--- CMakeLists.txt.orig 2023-05-21 04:59:24 UTC
+++ CMakeLists.txt
@@ -23,7 +23,7 @@ set(CMAKECONFIG_INSTALL_DIR "${ambit_INSTALL_CMAKEDIR}
#if (NOT TARGET Python::Module)
set(Python_ADDITIONAL_VERSIONS 3.11 3.10 3.9 3.8 3.7) # adjust with CMake minimum FindPythonInterp
- find_package(Python 3.7 COMPONENTS Interpreter Development NumPy REQUIRED)
+ find_package(Python ${FREEBSD_PYTHON_VER} EXACT COMPONENTS Interpreter Development NumPy REQUIRED)
message(STATUS "Found Python ${Python_VERSION_MAJOR}.${Python_VERSION_MINOR}: ${Python_EXECUTABLE} (found version ${Python_VERSION})")
#endif()