ports/databases/kdb/files/patch-CMakeLists.txt
Jason E. Hale 238049db9e databases/kdb: Fix build with ICU 75+
ICU 75+ requires at least c++17 for c++; adapt.

While here: Add LICENSE info, clean up whitespace, pet portclippy(1),
and remove false hope from 7 years ago that sla...ahem...child ports will
ever be a thing.

PR:		278420, 283577
Reported by:	jbeich, diizzy
2024-12-25 01:05:40 -05:00

12 lines
375 B
Text

Bump CXX standard to c++17. Required for ICU 75+.
--- CMakeLists.txt.orig 2019-03-26 18:44:44 UTC
+++ CMakeLists.txt
@@ -29,6 +29,7 @@ simple_option(BUILD_QCH "Build API documentation in QC
simple_option(BUILD_QCH "Build API documentation in QCH format" OFF)
# Dependencies
+set(CMAKE_CXX_STANDARD 17)
set(REQUIRED_QT_VERSION 5.4.0)
set(REQUIRED_KF5_VERSION 5.16.0)