mirror of
https://git.freebsd.org/ports.git
synced 2025-05-15 16:51:52 -04:00
- Remove some old pkg-message notes which are no longer effective Changelog: https://wiki.qemu.org/ChangeLog/7.2
20 lines
970 B
Text
20 lines
970 B
Text
--- meson.build.orig 2023-12-26 21:41:27 UTC
|
|
+++ meson.build
|
|
@@ -2717,14 +2717,10 @@ if have_system
|
|
fdt_opt = get_option('fdt')
|
|
if fdt_opt in ['enabled', 'auto', 'system']
|
|
have_internal = fs.exists(meson.current_source_dir() / 'dtc/libfdt/Makefile.libfdt')
|
|
- fdt = cc.find_library('fdt', kwargs: static_kwargs,
|
|
+ fdt = cc.find_library('fdt', kwargs: static_kwargs, dirs: '/usr/local/lib/',
|
|
required: fdt_opt == 'system' or
|
|
- fdt_opt == 'enabled' and not have_internal)
|
|
- if fdt.found() and cc.links('''
|
|
- #include <libfdt.h>
|
|
- #include <libfdt_env.h>
|
|
- int main(void) { fdt_find_max_phandle(NULL, NULL); return 0; }''',
|
|
- dependencies: fdt)
|
|
+ fdt_opt == 'enabled')
|
|
+ if fdt.found()
|
|
fdt_opt = 'system'
|
|
elif fdt_opt == 'system'
|
|
error('system libfdt requested, but it is too old (1.5.1 or newer required)')
|