ports/databases/mariadb101-client/files/patch-include_mysql_service__encryption.h
Bernard Spil df40f68fd0 databases/mariadb101-client: Update to 10.1.16
- -client was missig from the -server commit
  - post-install target to post-stage
  - Delete private headers
  - Add service_encryption.h patch
  - Fix scipts/CMakeLists.txt patch

PR:             211328
2016-07-24 10:23:45 +00:00

14 lines
459 B
C

--- include/mysql/service_encryption.h.orig 2015-12-23 15:33:29 UTC
+++ include/mysql/service_encryption.h
@@ -37,9 +37,11 @@ extern "C" {
#elif defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
#include <stdlib.h>
#else
+#ifndef __FreeBSD__
#include <alloca.h>
#endif
#endif
+#endif
/* returned from encryption_key_get_latest_version() */
#define ENCRYPTION_KEY_VERSION_INVALID (~(unsigned int)0)