mirror of
https://git.freebsd.org/ports.git
synced 2025-05-14 00:01:52 -04:00
Changelog: https://www.urlfilterdb.com/products/releases.html Major changes: * Fix: potential buffer overrun with clientid * ufdbgclient has new option to choose between UNIX and TCP socket Port changes: * remove unix socket compile option. It's no longer a compile option, there is 'socket-type' configuration option instead. * minor adjustments for configure PR: 278258 Reported by: Pavel Timofeev <timp87@gmail.com> (maintainer)
11 lines
512 B
Text
11 lines
512 B
Text
--- src/mtserver/Makefile.in.orig 2024-03-21 13:58:11 UTC
|
|
+++ src/mtserver/Makefile.in
|
|
@@ -16,7 +16,7 @@
|
|
|
|
CC = @CC@
|
|
CXX = @CXX@
|
|
-CFLAGS = @CFLAGS@ -I. -I.. -Wall -Wextra -Wmissing-prototypes -Wstrict-prototypes -Wold-style-definition
|
|
+CFLAGS = @CFLAGS@ -D__BSD_VISIBLE=1 -I. -I.. -Wall -Wextra -Wmissing-prototypes -Wstrict-prototypes -Wold-style-definition
|
|
CXXFLAGS= @CXXFLAGS@ -I. -I.. -Wall -Wextra -Wmissing-declarations
|
|
CPPFLAGS= @CPPFLAGS@
|
|
LDFLAGS = @LDFLAGS@ # -Wl,-z,relro -Wl,-z,now
|