ports/devel/py-undefined/files/patch-pyproject.toml
Po-Chuan Hsieh 6c7bd70255
devel/py-undefined: Add py-undefined 0.0.8
Ever needed a global object that act as None but not quite? Like for example
keyword argument for function, where None make sense, so you need a default
value.

One solution is to create as singleton object:
mysingleton = object()

Though it becomes difficult to track the singleton across libraries, and teach
users where to import this from. It's also relatively annoying use this
singleton across library.

Introducing undefined:
>>> import undefined
>>> from undefined import Undefined
>>> undefined is Undefined
True
2024-03-31 11:05:07 +08:00

11 lines
263 B
TOML

--- pyproject.toml.orig 2019-07-26 01:33:34 UTC
+++ pyproject.toml
@@ -1,6 +1,6 @@
[build-system]
-requires = ["flit"]
-build-backend = "flit.buildapi"
+requires = ["flit_core"]
+build-backend = "flit_core.buildapi"
[tool.flit.metadata]
module = "undefined"