mirror of
https://git.freebsd.org/ports.git
synced 2025-05-21 03:23:10 -04:00
- Fix unchecked block read/write vulnerability [2] Submitted by: nox [1] Obtained from: qemu cvs [2] Security: http://www.vuxml.org/freebsd/9cfbca7f-efb7-11dc-be01-0211060005df.html
24 lines
682 B
Text
24 lines
682 B
Text
Index: qemu/Makefile.target
|
|
@@ -179,7 +179,7 @@
|
|
|
|
#########################################################
|
|
|
|
-CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
|
|
+CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\" -I${LOCALBASE}/include
|
|
LIBS+=-lm
|
|
ifndef CONFIG_USER_ONLY
|
|
LIBS+=-lz
|
|
Index: qemu/vl.c
|
|
@@ -133,10 +133,12 @@
|
|
|
|
#define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
|
|
#define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
|
|
+#ifndef SMBD_COMMAND
|
|
#ifdef __sun__
|
|
#define SMBD_COMMAND "/usr/sfw/sbin/smbd"
|
|
#else
|
|
#define SMBD_COMMAND "/usr/sbin/smbd"
|
|
+#endif
|
|
#endif
|
|
|
|
//#define DEBUG_UNUSED_IOPORT
|