ports/sysutils/genimage/files/patch-Makefile.am
Tijl Coosemans c8eeb158e4 devel/automake: Update to 1.17
biology/libneurosim: Fix use of libltdl.

dns/ddclient: Take out -Werror.

lang/sdcc:
- Patching ARCH is no longer needed.  Remove it because it touched some
  configure.ac files and that causes other autotools files to appear
  out-of-date.
- Run autoreconf in WRKSRC/device/lib/pic14 because aclocal.m4 and
  config.h.in appear out-of-date.

net/rpki-client: Patch Makefile.in instead of Makefile.am to avoid
autotools.

sysutils/genimage: Run configure with --disable-silent-rules because
upstream changed the default to silent and when silent rules are
enabled it also runs make with --no-print-directory which is a gmake
flag.  Patch Makefile.am so it uses --no-print-directory depending on
the actual verbosity instead of the default.

PR:		280277
Exp-run by:	antoine
2024-07-20 13:27:02 +02:00

12 lines
299 B
Text

--- Makefile.am.orig 2024-07-04 14:07:20 UTC
+++ Makefile.am
@@ -1,6 +1,6 @@
-if BUILD_SILENTLY
-AM_MAKEFLAGS = --no-print-directory
-endif
+AM_MAKEFLAGS = $(AM_MAKEFLAGS_@AM_V@)
+AM_MAKEFLAGS_ = $(AM_MAKEFLAGS_@AM_DEFAULT_V@)
+AM_MAKEFLAGS_0 = --no-print-directory
EXTRA_DIST = \
README.rst \