mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
biology/libneurosim: Fix use of libltdl. dns/ddclient: Take out -Werror. lang/sdcc: - Patching ARCH is no longer needed. Remove it because it touched some configure.ac files and that causes other autotools files to appear out-of-date. - Run autoreconf in WRKSRC/device/lib/pic14 because aclocal.m4 and config.h.in appear out-of-date. net/rpki-client: Patch Makefile.in instead of Makefile.am to avoid autotools. sysutils/genimage: Run configure with --disable-silent-rules because upstream changed the default to silent and when silent rules are enabled it also runs make with --no-print-directory which is a gmake flag. Patch Makefile.am so it uses --no-print-directory depending on the actual verbosity instead of the default. PR: 280277 Exp-run by: antoine
27 lines
1 KiB
Text
27 lines
1 KiB
Text
--- Makefile.in.orig 2024-03-02 20:52:00 UTC
|
|
+++ Makefile.in
|
|
@@ -889,22 +889,10 @@ install-data-hook:
|
|
|
|
install-data-hook:
|
|
-@if [ ! -d "$(DESTDIR)$(RPKI_BASE_DIR)" ]; then \
|
|
- if [ "`id -u`" = "0" ]; then \
|
|
- $(INSTALL) -m 755 -o $(RPKI_USER) -d "$(DESTDIR)$(RPKI_BASE_DIR)"; \
|
|
- else \
|
|
- $(INSTALL) -m 755 -d "$(DESTDIR)$(RPKI_BASE_DIR)"; \
|
|
- echo "Warning: Unprivileged permissions, remember to run" \
|
|
- "'chown $(RPKI_USER) $(DESTDIR)$(RPKI_BASE_DIR)'"; \
|
|
- fi \
|
|
+ $(INSTALL) -m 755 -d "$(DESTDIR)$(RPKI_BASE_DIR)"; \
|
|
fi
|
|
-@if [ ! -d "$(DESTDIR)$(RPKI_OUT_DIR)" ]; then \
|
|
- if [ "`id -u`" = "0" ]; then \
|
|
- $(INSTALL) -m 755 -o $(RPKI_USER) -d "$(DESTDIR)$(RPKI_OUT_DIR)"; \
|
|
- else \
|
|
- $(INSTALL) -m 755 -d "$(DESTDIR)$(RPKI_OUT_DIR)"; \
|
|
- echo "Warning: Unprivileged permissions, remember to run" \
|
|
- "'chown $(RPKI_USER) $(DESTDIR)$(RPKI_OUT_DIR)'"; \
|
|
- fi \
|
|
+ $(INSTALL) -m 755 -d "$(DESTDIR)$(RPKI_OUT_DIR)"; \
|
|
fi
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|