mirror of
https://git.freebsd.org/ports.git
synced 2025-05-28 17:06:32 -04:00
family -- first public patchset of native Sun JDK 1.5.0 port. Most valuable addition of this patchset is native amd64 support. And special thanks goes to Daniel Seuffert <ds@freeBSD.org> for making it possible by providing amd64 hardware. This patchset was tested on following configurations: i386/4.10, i386/5.3, amd64/5.3. 5.3-RELEASE support is quite strong and shown no huge visible problems over last week. But even mentioning above note, keep in mind -- THIS IS ALPHA PATCHSET and suitable for testers/developers ONLY! Known issues are including (but for sure not limited to): . Browser plugin support is missing . JVMTI, JDWP and JMX are not tested yet . FreeBSD i386/4.10 support is suffering from hidden memory allocation failres (ideas and patches are welcome) NOTE ABOUT BOOTSTRAPING: It's possible to bootstrap jdk 1.5.0 using jdk 1.4.2 (either native or linux one). There's no need to have java/linux_jdk15 installed and working. Supported by: FreeBSD Foundation
15 lines
469 B
Text
15 lines
469 B
Text
$FreeBSD$
|
|
|
|
--- ../../j2se/make/java/instrument/Makefile.orig Thu Jan 13 02:04:44 2005
|
|
+++ ../../j2se/make/java/instrument/Makefile Thu Jan 13 02:05:03 2005
|
|
@@ -72,8 +72,8 @@
|
|
else
|
|
ifeq ($(PLATFORM), bsd)
|
|
ifneq ($(TRUE_PLATFORM), NetBSD)
|
|
- OTHER_INCLUDES += -I/usr/local/include
|
|
- OTHER_LDLIBS += -L/usr/local/lib -liconv
|
|
+ OTHER_INCLUDES += -I${LOCALBASE}/include
|
|
+ OTHER_LDLIBS += -L${LOCALBASE}/lib -liconv
|
|
endif
|
|
else
|
|
OTHER_LDLIBS = -lnsl -ldl
|