ports/sysutils/conky/files/patch-CMakeLists.txt
Fernando Apesteguía cfc9a1e749 sysutils/conky{-awesome}: update to 1.21.2
Remove upstreamed patches.

ChangeLog: https://github.com/brndnmtthws/conky/releases/tag/v1.21.2

Features

 * Don't include the -pre in install dir path.

Bug fixes

 * Fix build with specific option combination.
 * Remove dpi scaling of minimum_width & maximum_width
 * Make dpi_scale match original behavior
 * Don't test colour names without map
 * Fix typo in conky.cc

Miscellaneous

 * Bump version
 * Docker: don't login without creds
2024-05-31 08:31:24 +02:00

21 lines
739 B
Text

--- CMakeLists.txt.orig 2024-05-30 14:36:45 UTC
+++ CMakeLists.txt
@@ -79,12 +79,15 @@ if(NOT DEFINED DOC_PATH)
endif()
if(NOT DEFINED DOC_PATH)
- set(DOC_PATH "share/doc/${CPACK_PACKAGE_NAME}-${RELEASE_VERSION}")
+ set(DOC_PATH "share/doc/${CPACK_PACKAGE_NAME}")
endif(NOT DEFINED DOC_PATH)
-set(DOC_FILES extras/convert.lua data/conky_no_x11.conf data/conky.conf)
+if(NOT DEFINED SAMPLE_PATH)
+ set(SAMPLE_PATH "share/examples/${CPACK_PACKAGE_NAME}")
+endif(NOT DEFINED SAMPLE_PATH)
+set(SAMPLE_FILES extras/convert.lua data/conky_no_x11.conf data/conky.conf)
-install(FILES ${DOC_FILES} DESTINATION ${DOC_PATH})
+install(FILES ${SAMPLE_FILES} DESTINATION ${SAMPLE_PATH})
if(CHECK_CODE_QUALITY)
find_package(ClangTidy)