ports/math/openblas/files/patch-exports_Makefile
Eijiro Shibusawa 84ca7effd3 math/openblas: upgrade to 0.3.25
Releases notes at <https://github.com/OpenMathLib/OpenBLAS/releases>.

PR:		273219
Exp-run by:	antoine@
2023-12-12 20:03:50 +01:00

11 lines
406 B
Text

--- exports/Makefile.orig 2023-04-01 20:18:01 UTC
+++ exports/Makefile
@@ -222,7 +222,7 @@ else
endif
$(CC) $(CFLAGS) $(LDFLAGS) -shared -o ../$(LIBSONAME) \
-Wl,--whole-archive $< -Wl,--no-whole-archive \
- $(FEXTRALIB) $(EXTRALIB)
+ -Wl,-soname,$(LIBSONAME) $(FEXTRALIB) $(EXTRALIB)
$(CC) $(CFLAGS) $(LDFLAGS) -w -o linktest linktest.c ../$(LIBSONAME) $(FEXTRALIB) && echo OK.
rm -f linktest