mirror of
https://git.freebsd.org/ports.git
synced 2025-05-17 17:43:11 -04:00
Releases notes at <https://github.com/OpenMathLib/OpenBLAS/releases>. PR: 273219 Exp-run by: antoine@
11 lines
406 B
Text
11 lines
406 B
Text
--- exports/Makefile.orig 2023-04-01 20:18:01 UTC
|
|
+++ exports/Makefile
|
|
@@ -222,7 +222,7 @@ else
|
|
endif
|
|
$(CC) $(CFLAGS) $(LDFLAGS) -shared -o ../$(LIBSONAME) \
|
|
-Wl,--whole-archive $< -Wl,--no-whole-archive \
|
|
- $(FEXTRALIB) $(EXTRALIB)
|
|
+ -Wl,-soname,$(LIBSONAME) $(FEXTRALIB) $(EXTRALIB)
|
|
$(CC) $(CFLAGS) $(LDFLAGS) -w -o linktest linktest.c ../$(LIBSONAME) $(FEXTRALIB) && echo OK.
|
|
rm -f linktest
|
|
|