ports/math/metis/files/patch-programs_CMakeLists.txt
Steve Wills 9403d24029 math/metis: update IDXTYPEWIDTH to 64 on 64 bit platforms
While here, pet portlint

PR:		219749
Submitted by:	pfg
2019-01-15 12:52:46 +00:00

17 lines
534 B
Text

--- programs/CMakeLists.txt.orig 2013-03-30 16:24:45 UTC
+++ programs/CMakeLists.txt
@@ -13,9 +13,14 @@ foreach(prog gpmetis ndmetis mpmetis m2gmetis graphchk
# target_link_libraries(${prog} metis profiler)
endforeach(prog)
+# Borrowed from metis-edf
+file(GLOB metis_h *.h)
+
if(METIS_INSTALL)
install(TARGETS gpmetis ndmetis mpmetis m2gmetis graphchk cmpfillin
RUNTIME DESTINATION bin)
+# Borrowed from metis-edf
+ install(FILES ${metis_h} DESTINATION include/programs)
endif()
# Try to find subversion revision.