ports/devel/py-sip/files/patch-sipbuild_project.py
Jason E. Hale a7e4468b08 devel/py-sip: Fix regressions in code generator
The code generator was ported from C to Python for version 6.8.0 and
there were a few typos and bugs in it causing build failure of some
ports like graphics/qgis.

Reported by:	rhurlin
2023-12-10 01:20:51 -05:00

14 lines
525 B
Python

--- sipbuild/project.py.orig 2023-11-30 12:14:32 UTC
+++ sipbuild/project.py
@@ -387,9 +387,9 @@ class Project(AbstractProject, Configurable):
generator=None, wheel_tag=None, generator_version=None):
""" Return a sequence of command line arguments to invoke sip-distinfo.
"""
-
+ flavor = '{}-{}.{}'.format(sip_distinfo, self.py_major_version, self.py_minor_version)
args = [
- sip_distinfo,
+ flavor,
'--inventory',
inventory,