mirror of
https://git.freebsd.org/ports.git
synced 2025-05-15 08:41:51 -04:00
The code generator was ported from C to Python for version 6.8.0 and there were a few typos and bugs in it causing build failure of some ports like graphics/qgis. Reported by: rhurlin
14 lines
525 B
Python
14 lines
525 B
Python
--- sipbuild/project.py.orig 2023-11-30 12:14:32 UTC
|
|
+++ sipbuild/project.py
|
|
@@ -387,9 +387,9 @@ class Project(AbstractProject, Configurable):
|
|
generator=None, wheel_tag=None, generator_version=None):
|
|
""" Return a sequence of command line arguments to invoke sip-distinfo.
|
|
"""
|
|
-
|
|
+ flavor = '{}-{}.{}'.format(sip_distinfo, self.py_major_version, self.py_minor_version)
|
|
args = [
|
|
- sip_distinfo,
|
|
+ flavor,
|
|
|
|
'--inventory',
|
|
inventory,
|