ports/comms/gnokii/files/patch-utils_sendsms
Guido Falsi ca17004b6d comms/gnokii: Cleanup and modernize port
- Remove pkg-install, all it was doing is now done from pkg-plist [1]
- Fix sendsms script to work with sh
- Use shebangfix in place of REINPLACE_CMD
- Remove unneeded REINPLACE_CMDs
- Remove bogus SMSDDB option, and use OPTIONS_GROUP in place of OPTIONS_MULTI
- Remove duplicate "gnome" from X11_USES (already in global USES)
- Add missing dependency on harfbuzz when X11 is enabled
- Remove unneeded "-p" from ${MKDIR}
- Delete an old, unused, patch file

Reported by:	bapt [1]
2022-07-27 22:30:53 +02:00

26 lines
848 B
Text

--- utils/sendsms.orig 2011-12-02 14:53:04 UTC
+++ utils/sendsms
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
###############################################################################
# SENDSMS -- Script to send sms by 'gnokii'
# Author : Gabriele Zappi - Rimini <gzappi@inwind.it>
@@ -342,7 +342,7 @@ parse_stdin $*
# help
# fi
-if ! type -all "dialog" >/dev/null 2>&1 ; then
+if ! type "dialog" >/dev/null 2>&1 ; then
echo
echo "${PROGNAME}: error:"
echo "Can't find 'dialog', i can't run without 'dialog' on your system."
@@ -354,7 +354,7 @@ if [ $SW_SKIPGNOKITST = no ] ; then
fi
if [ $SW_SKIPGNOKITST = no ] ; then
- if ! type -all "$GNOKII" >/dev/null 2>&1 ; then
+ if ! type "$GNOKII" >/dev/null 2>&1 ; then
echo
echo "${PROGNAME}: error:"
echo "Can't find 'gnokii'. This script needs 'gnokii' in order to work."