ports/multimedia/ffmpeg/files/patch-configure
Jan Beich c48fcbfe55 multimedia/ffmpeg: simplify ARCH workaround
ARCH is clobbered via .MAKEFLAGS in Mk/bsd.port.mk since r20327.

Approved by:	portmgr blanket
2016-12-19 01:08:39 +00:00

48 lines
1.4 KiB
Text

--- configure.orig 2016-10-27 16:17:39 UTC
+++ configure
@@ -3189,12 +3189,7 @@ target_os_default=$(tolower $(uname -s))
host_os=$target_os_default
# machine
-if test "$target_os_default" = aix; then
- arch_default=$(uname -p)
- strip_default="strip -X32_64"
-else
- arch_default=$(uname -m)
-fi
+arch_default=$(uname -p)
cpu="generic"
intrinsics="none"
@@ -6213,6 +6208,9 @@ elif enabled llvm_gcc; then
elif enabled clang; then
check_cflags -mllvm -stack-alignment=16
check_cflags -mstack-alignment=16
+ if enabled x86_32; then
+ check_cflags -mstackrealign
+ fi
check_cflags -Qunused-arguments
check_cflags -Werror=implicit-function-declaration
check_cflags -Werror=missing-prototypes
@@ -6799,7 +6797,7 @@ exec_prefix=\${prefix}
libdir=$libdir
includedir=$incdir
-Name: $name
+Name: ${name}${build_suffix}
Description: $comment
Version: $version
Requires: $(enabled shared || echo $requires)
@@ -6813,10 +6811,10 @@ EOF
mkdir -p doc/examples/pc-uninstalled
includedir=${source_path}
[ "$includedir" = . ] && includedir="\${pcfiledir}/../../.."
- cat <<EOF > doc/examples/pc-uninstalled/$name.pc
+ cat <<EOF > doc/examples/pc-uninstalled/${name}${build_suffix}.pc
prefix=
exec_prefix=
-libdir=\${pcfiledir}/../../../$name
+libdir=\${pcfiledir}/../../../${name}${build_suffix}
includedir=${includedir}
Name: $name