mirror of
https://git.freebsd.org/ports.git
synced 2025-05-29 01:16:28 -04:00
As far as I (the author) knows, sshuttle is the only program that solves the following common case: * Your client machine (or router) is Linux, FreeBSD, or MacOS. * You have access to a remote network via ssh. * You don't necessarily have admin access on the remote network. * The remote network has no VPN, or only stupid/complex VPN protocols (IPsec, PPTP, etc). Or maybe you are the admin and you just got frustrated with the awful state of VPN tools. * You don't want to create an ssh port forward for every single host/port on the remote network. * You hate openssh's port forwarding because it's randomly slow and/or stupid. * You can't use openssh's PermitTunnel feature because it's disabled by default on openssh servers; plus it does TCP-over-TCP, which has terrible performance WWW: https://github.com/sshuttle/sshuttle While I'm here, patch out pytest-runner from setup_requires and add it to tests_require. It's a test dependency, and pytest upstream shouldn't 'recommend' otherwise in its 'Usage:' docs. [1] https://github.com/sshuttle/sshuttle/issues/115 Requested by: John Kozubik (rsync.net, Inc) via freebsd-jobs
19 lines
587 B
Python
19 lines
587 B
Python
--- setup.py.orig 2016-10-10 04:57:26 UTC
|
|
+++ setup.py
|
|
@@ -36,7 +36,7 @@ setup(
|
|
'write_to': "sshuttle/version.py",
|
|
'version_scheme': version_scheme,
|
|
},
|
|
- setup_requires=['setuptools_scm', 'pytest-runner'],
|
|
+ setup_requires=['setuptools_scm'],
|
|
# version=version,
|
|
url='https://github.com/sshuttle/sshuttle',
|
|
author='Brian May',
|
|
@@ -61,6 +61,6 @@ setup(
|
|
'sshuttle = sshuttle.cmdline:main',
|
|
],
|
|
},
|
|
- tests_require=['pytest', 'mock'],
|
|
+ tests_require=['pytest', 'pytest-runner', 'mock'],
|
|
keywords="ssh vpn",
|
|
)
|