mirror of
https://git.freebsd.org/ports.git
synced 2025-05-14 08:11:50 -04:00
o Update URL in MASTER_SITES to current address o Update MAINTAINER o Remove post-patch target as it is not needed - Use LDFLAGS instead of the non-standard variable ADDITIONALLINKOPTIONS. - Replace "${REINPLACE_CMD} 's,log2,gfan_log2,g'" by appropriate patch files as the command triggers multiple warnings. log2 is a macro defined in src/log.h. The name of this macro is in conflict with the function log2 from math.h. To avoid errors when compiling the code, the above renaming is necessary. Furthermore, PHB 4.4.3 strongly suggests using patch files instead of REINPLACE_CMD for static content. o Sort pkg-plist alphabetically as required by PHB 3.2.2 o Shorten pkg-descr and make it less technical PR: 250879 Submitted by: Moritz Schmitt (maintainer)
33 lines
1 KiB
C++
33 lines
1 KiB
C++
--- src/reversesearch.cpp.orig 2017-06-20 14:47:37 UTC
|
|
+++ src/reversesearch.cpp
|
|
@@ -65,7 +65,7 @@ int ReverseSearch::treeSize(PolynomialSet &groebnerBas
|
|
static int n;
|
|
n++;
|
|
if(!(n%10))
|
|
- log2 fprintf(Stderr,"%i %i\n",n,depth);
|
|
+ gfan_log2 fprintf(Stderr,"%i %i\n",n,depth);
|
|
}
|
|
|
|
int s=1;
|
|
@@ -144,17 +144,17 @@ int ReverseSearch::treeSize(PolynomialSet &groebnerBas
|
|
|
|
PolynomialSet ReverseSearch::findRoot(PolynomialSet groebnerBasis)
|
|
{
|
|
- log2 fprintf(Stderr,"Computing root\n");
|
|
- log2 buchberger(&groebnerBasis,termOrder);
|
|
+ gfan_log2 fprintf(Stderr,"Computing root\n");
|
|
+ gfan_log2 buchberger(&groebnerBasis,termOrder);
|
|
|
|
IntegerVector edge;
|
|
while(computeSearchEdge(groebnerBasis,&edge))
|
|
{
|
|
- log2 AsciiPrinter(Stderr).printVector(edge);
|
|
+ gfan_log2 AsciiPrinter(Stderr).printVector(edge);
|
|
groebnerBasis=flip(groebnerBasis,edge);
|
|
}
|
|
|
|
- log2 fprintf(Stderr,"Done computing root\n");
|
|
+ gfan_log2 fprintf(Stderr,"Done computing root\n");
|
|
return groebnerBasis;
|
|
}
|
|
|