ports/math/gfan/files/patch-src_gfanlib__polyhedralfan.cpp
Mikael Urankar ecbb96a533 math/gfan: pass maintainership
o Update URL in MASTER_SITES to current address
o Update MAINTAINER
o Remove post-patch target as it is not needed
	- Use LDFLAGS instead of the non-standard variable
	  ADDITIONALLINKOPTIONS.
	- Replace "${REINPLACE_CMD} 's,log2,gfan_log2,g'" by appropriate
	  patch files as the command triggers multiple warnings. log2 is
	  a macro defined in src/log.h. The name of this macro is in
	  conflict with the function log2 from math.h. To avoid errors
	  when compiling the code, the above renaming is necessary.
	  Furthermore, PHB 4.4.3 strongly suggests using patch files
	  instead of REINPLACE_CMD for static content.
o Sort pkg-plist alphabetically as required by PHB 3.2.2
o Shorten pkg-descr and make it less technical

PR:		250879
Submitted by:	Moritz Schmitt (maintainer)
2020-12-04 18:17:32 +00:00

38 lines
1.6 KiB
C++

--- src/gfanlib_polyhedralfan.cpp.orig 2017-06-20 14:47:37 UTC
+++ src/gfanlib_polyhedralfan.cpp
@@ -221,10 +221,10 @@ PolyhedralFan PolyhedralFan::fullComplex()const
while(1)
{
- log2 debug<<"looping";
+ gfan_log2 debug<<"looping";
bool doLoop=false;
PolyhedralFan facets=ret.facetComplex();
- log2 debug<<"number of facets"<<facets.size()<<"\n";
+ gfan_log2 debug<<"number of facets"<<facets.size()<<"\n";
for(PolyhedralConeList::const_iterator i=facets.cones.begin();i!=facets.cones.end();i++)
if(!ret.contains(*i))
{
@@ -561,7 +561,7 @@ std::string PolyhedralFan::toString(int flags)const
static int t;
// log1 fprintf(Stderr,"Adding faces of cone %i\n",t++);
}
-// log2 fprintf(Stderr,"Dim: %i\n",i->dimension());
+// gfan_log2 fprintf(Stderr,"Dim: %i\n",i->dimension());
addFacesToSymmetricComplex(symCom,*i,i->getHalfSpaces(),generatorsOfLinealitySpace);
}
@@ -706,11 +706,11 @@ PolyhedralFan PolyhedralFan::readFan(string const &fil
PolyhedralFan ret(n);
- log2 cerr<< "Number of orbits to expand "<<cones.size()<<endl;
+ gfan_log2 cerr<< "Number of orbits to expand "<<cones.size()<<endl;
for(int i=0;i<cones.size();i++)
if(coneIndices==0 || coneIndices->count(i))
{
- log2 cerr<<"Expanding symmetries of cone"<<endl;
+ gfan_log2 cerr<<"Expanding symmetries of cone"<<endl;
{
IntegerVectorList coneRays;
for(list<int>::const_iterator j=cones[i].begin();j!=cones[i].end();j++)