mirror of
https://git.freebsd.org/ports.git
synced 2025-05-14 08:11:50 -04:00
o Update URL in MASTER_SITES to current address o Update MAINTAINER o Remove post-patch target as it is not needed - Use LDFLAGS instead of the non-standard variable ADDITIONALLINKOPTIONS. - Replace "${REINPLACE_CMD} 's,log2,gfan_log2,g'" by appropriate patch files as the command triggers multiple warnings. log2 is a macro defined in src/log.h. The name of this macro is in conflict with the function log2 from math.h. To avoid errors when compiling the code, the above renaming is necessary. Furthermore, PHB 4.4.3 strongly suggests using patch files instead of REINPLACE_CMD for static content. o Sort pkg-plist alphabetically as required by PHB 3.2.2 o Shorten pkg-descr and make it less technical PR: 250879 Submitted by: Moritz Schmitt (maintainer)
11 lines
681 B
C++
11 lines
681 B
C++
--- src/app_secondaryfan.cpp.orig 2017-06-20 14:47:37 UTC
|
|
+++ src/app_secondaryfan.cpp
|
|
@@ -385,7 +385,7 @@ class SecondaryFanApplication : public GFanApplication
|
|
for(PolyhedralFan::coneIterator i=f1.conesBegin();i!=f1.conesEnd();i++)
|
|
{
|
|
static int a;
|
|
- log2 cerr<<"Processing Cone "<<a++<<" which has dimension "<<i->dimension()<<endl;
|
|
+ gfan_log2 cerr<<"Processing Cone "<<a++<<" which has dimension "<<i->dimension()<<endl;
|
|
SecondaryFanTraverser traverser(triangulationWithFullDimensionalIntersection(t,*i),*i);
|
|
SymmetricTargetCounterInterrupted target2(target,optionInterrupt.getValue());
|
|
symmetricTraverse(traverser,target2,&s);
|