mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 07:41:50 -04:00
o Update URL in MASTER_SITES to current address o Update MAINTAINER o Remove post-patch target as it is not needed - Use LDFLAGS instead of the non-standard variable ADDITIONALLINKOPTIONS. - Replace "${REINPLACE_CMD} 's,log2,gfan_log2,g'" by appropriate patch files as the command triggers multiple warnings. log2 is a macro defined in src/log.h. The name of this macro is in conflict with the function log2 from math.h. To avoid errors when compiling the code, the above renaming is necessary. Furthermore, PHB 4.4.3 strongly suggests using patch files instead of REINPLACE_CMD for static content. o Sort pkg-plist alphabetically as required by PHB 3.2.2 o Shorten pkg-descr and make it less technical PR: 250879 Submitted by: Moritz Schmitt (maintainer)
15 lines
758 B
C++
15 lines
758 B
C++
--- src/app_doesidealcontain.cpp.orig 2017-06-20 14:47:37 UTC
|
|
+++ src/app_doesidealcontain.cpp
|
|
@@ -52,9 +52,9 @@ class DoesIdealContainApplication : public GFanApplica
|
|
for(PolynomialSet::const_iterator i=b.begin();i!=b.end();i++)
|
|
{
|
|
Polynomial remainder=division(multiplier* *i,a,LexicographicTermOrder());
|
|
- log2 AsciiPrinter(Stderr).printString("Remainder: ");
|
|
- log2 AsciiPrinter(Stderr).printPolynomial(remainder);
|
|
- log2 AsciiPrinter(Stderr).printNewLine();
|
|
+ gfan_log2 AsciiPrinter(Stderr).printString("Remainder: ");
|
|
+ gfan_log2 AsciiPrinter(Stderr).printPolynomial(remainder);
|
|
+ gfan_log2 AsciiPrinter(Stderr).printNewLine();
|
|
if(!remainder.isZero())
|
|
{
|
|
log1 AsciiPrinter(Stderr).printString("Polynomial not in ideal: ");
|