mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 07:41:50 -04:00
- Add an option to enable limited Cairo rendering support - Do not strip static libraries upon installation as this breaks linking against them (the case for `x11/flruler') - Restore `files/patch-src_Makefile' which was ditched in r447379 (commit2a288980b3
) in favor of `post-install' target because of the above and now this code is mature enough and should be less fragile to patch statically - Garbage-collect no longer useful patch added in r138020 (commit2a70195a32
) back in 2005 which now makes `-lm' appear twice in the fltk-config(1)'s LDFLAGS outputs - Shorten local variable name in the `post-patch' target Reported by: pkg-fallout
17 lines
855 B
Text
17 lines
855 B
Text
--- cairo/Makefile.orig 2023-12-09 13:58:40 UTC
|
|
+++ cairo/Makefile
|
|
@@ -98,12 +98,13 @@ clean:
|
|
install: $(CAIROLIBNAME) $(CAIRODSONAME)
|
|
echo "Installing libfltk_cairo$(LIBEXT) in $(libdir)..."
|
|
-$(INSTALL_DIR) $(DESTDIR)$(libdir)
|
|
- $(INSTALL_LIB) $(CAIROLIBNAME) $(DESTDIR)$(libdir)
|
|
+ $(INSTALL_DATA) $(CAIROLIBNAME) $(DESTDIR)$(libdir)
|
|
|
|
if test x$(CAIRODSONAME) = xlibfltk_cairo.so.$(FL_DSO_VERSION); then\
|
|
$(RM) $(DESTDIR)$(libdir)/libfltk_cairo.so*;\
|
|
$(INSTALL_LIB) libfltk_cairo.so.$(FL_DSO_VERSION) $(DESTDIR)$(libdir); \
|
|
$(LN) libfltk_cairo.so.$(FL_DSO_VERSION) $(DESTDIR)$(libdir)/libfltk_cairo.so;\
|
|
+ $(LN) libfltk_cairo.so.$(FL_DSO_VERSION) $(DESTDIR)$(libdir)/libfltk_cairo.so.$(FL_DSO_VERSION:R);\
|
|
fi
|
|
if test x$(CAIRODSONAME) = xsrc/libfltk_cairo.sl.$(FL_DSO_VERSION); then\
|
|
$(RM) $(DESTDIR)$(libdir)/libfltk_cairo.sl*;\
|