mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
The Open Vulnerability Assessment System (OpenVAS) is a framework of several services and tools offering a comprehensive and powerful vulnerability scanning and vulnerability management solution. This package contains the OpenVAS Manager which provides services on top of the OpenVAS Scanner to manage scan results, configurations and user access control. WWW: http://www.openvas.org/
20 lines
644 B
Text
20 lines
644 B
Text
--- CMakeLists.txt.orig 2017-06-21 05:05:37.000000000 -0500
|
|
+++ CMakeLists.txt 2017-07-28 23:43:57.479141000 -0500
|
|
@@ -155,7 +155,7 @@
|
|
endif (NOT LIBDIR)
|
|
|
|
if (NOT LOCALSTATEDIR)
|
|
- set (LOCALSTATEDIR "${CMAKE_INSTALL_PREFIX}/var")
|
|
+ set (LOCALSTATEDIR "/var")
|
|
endif (NOT LOCALSTATEDIR)
|
|
|
|
if (NOT DATADIR)
|
|
@@ -291,7 +291,7 @@
|
|
|
|
## Program
|
|
|
|
-set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector")
|
|
+set (HARDENING_FLAGS "-Wformat -Wformat-security")
|
|
set (LINKER_HARDENING_FLAGS "-Wl,-z,relro -Wl,-z,now")
|
|
|
|
set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
|