ports/security/esteidfirefoxplugin/files/patch-Makefile
Tijl Coosemans c4e12a20bf New port: security/esteidfirefoxplugin
A Firefox plugin that enables in-browser digital signing with Estonian ID
cards.

PR:		194300
Submitted by:	toomas.aas@raad.tartu.ee
Reviewed by:	marino
2015-10-09 09:06:16 +00:00

15 lines
1 KiB
Text

--- ./Makefile.orig 2013-04-29 17:49:10.000000000 +0300
+++ ./Makefile 2014-09-10 16:37:31.000000000 +0300
@@ -1,10 +1,10 @@
# EstEID Browser Plugin
-CC = gcc
+CC = cc
COMMON_HEADERS = common/esteid_certinfo.h common/pkcs11_errors.h common/esteid_log.h common/esteid_sign.h common/esteid_timer.h common/esteid_time.h common/l10n.h common/labels.h common/esteid_map.h common/esteid_dialog_common.h
COMMON_SOURCES = common/esteid_certinfo.c common/pkcs11_errors.c common/esteid_log.c common/esteid_sign.c common/esteid_timer.c common/esteid_time.c common/l10n.c common/l10n-linux.c common/esteid_map.c common/esteid_dialog_common.c
C_FLAGS = -g -O2 -std=gnu99 -Wall $(CPPFLAGS)
I_FLAGS = -Iinclude -Icommon `pkg-config --cflags gtk+-2.0`
-L_FLAGS = -ldl -lcrypto -lpthread `pkg-config --libs gtk+-2.0`
+L_FLAGS = -lcrypto -lpthread `pkg-config --libs gtk+-2.0`
D_FLAGS = -DXP_UNIX -DMOZ_X11
PLUGIN_HEADERS = firefox/plugin.h firefox/plugin-class.h firefox/cert-class.h
PLUGIN_SOURCES = firefox/plugin.c firefox/plugin-class.c firefox/cert-class.c