ports/astro/kstars/files/patch-kstars_CMakeLists.txt
Adriaan de Groot be37e95804 astro/kstars: update to 3.7.3, latest upstream
Release notes for releases jumped-over:
	https://knro.blogspot.com/2024/10/kstars-v373-is-released.html
	https://knro.blogspot.com/2024/08/kstars-372-released.html
	https://knro.blogspot.com/2024/04/kstars-370-is-released.html

Reported of the PR provided an update to 3.7.0, which I used
and then extended to the latest release.

PR:	279291
2024-12-02 12:02:14 +01:00

26 lines
1.1 KiB
Text

Fix linking without INDI
ld: error: undefined symbol: pthread_create
>>> referenced by __threading_support:378 (/usr/include/c++/v1/__threading_support:378)
>>> supernovaecomponent.cpp.o:(std::__1::thread::thread<io::detail::AsynchronousReader::init(std::__1::unique_ptr<io::ByteSourceBase,
std::__1::default_delete<io::ByteSourceBase>>)::'lambda'(), void>(io::detail::AsynchronousReader::init(std::__1::unique_ptr<io::ByteSourceBase,
std::__1::default_delete<io::ByteSourceBase>>)::'lambda'()&&)) in archive lib/libKStarsLib.a
--- kstars/CMakeLists.txt.orig 2024-10-01 07:34:49 UTC
+++ kstars/CMakeLists.txt
@@ -1314,6 +1314,7 @@ IF (NOT ANDROID)
${ZLIB_LIBRARIES}
Eigen3::Eigen
GSL::gsl
+ Threads::Threads
)
if (BUILD_QT5)
target_link_libraries(KStarsLib
@@ -1412,7 +1413,6 @@ if(INDI_FOUND)
## Linux + MacOS Lite: Requires INDI Qt5 Client
## Android: Requires INDI Qt5 Client built for Android
if (NOT ANDROID)
- target_link_libraries(KStarsLib ${CMAKE_THREAD_LIBS_INIT})
endif ()
if(WIN32 OR ANDROID)